I recently downloaded Xcode directly from apple.com (I didn't use the App Store). Now I try to open it, but it just says "Checking Xcode", it loads until the progress bar reaches 100% and then it does nothing.

What can I do?


5 Answers 5

  1. Delete all files at

  2. Manually install Developer Tools from Terminal by running

    xcode-select --install
  3. Reinstall "XcodeSystemResources.pkg" from contents of Xcode.app itself


Finally Xcode 9.0.1 (9A1004) worked perfectly.

  • This also helps when Xcode was installed and suddenly doesn't work. Here there was just some Xcode bounces and Xcode closed again. After running the above, works fine again.
    – brainray
    Commented Jul 16, 2018 at 15:43

I see that you said that you downloaded Xcode from Apple.com, so you must have downloaded a beta version. The same issue also happened to me when the Xcode 7 beta came out. For whatever reason this sometimes happens when trying to run the betas.

Unless there is a big reason why you can't (some feature you need for app development), just download Xcode from the Mac App Store and you shouldn't run into this issue again.

  • The reason why I downloaded it from developer.apple.com/downloads was that I couldn't download it from the App Store.
    – user162520
    Commented Dec 21, 2015 at 22:29
  • @Alex How come? Commented Dec 21, 2015 at 22:30
  • Because it took extremely long and I wasn't sure if it was downloading at all. So I canceled the download.
    – user162520
    Commented Dec 21, 2015 at 22:34
  • developer.apple.com doesn't only host beta versions. The Xcode Code Signature verification (the screenshot) takes a very long time, since it must verify around 7GB worth of data. Just download it from the App Store, and remember it should take a while. You can check on the progress by going into the Launchpad. Commented Dec 22, 2015 at 1:51
  • I downloaded it now from App Store, it works. Thank you guys.
    – user162520
    Commented Dec 28, 2015 at 15:02

On MacOS High Sierra (10.13.4) I started XCode (9.3) and it immediately quit without any message. The solution was to

Find and close any running app that takes too much system resources (CPU, memory)!

In my case Android Studio got stuck and was running with 400% CPU power.

  • This should be a comment
    – JGallardo
    Commented Nov 20, 2019 at 1:37

I had a simmilar issue. I solved it following this answer:

  1. removing the old tools (sudo rm -rf /Library/Developer/CommandLineTools)
  2. install xcode command line tools again (xcode-select --install).

I use xed . to open my project/workspace.

I accidentally hit xed / and that some how put Xcode is a weird state that upon opening any project Xcode would just open a spinning wheel.

I restarted and deleted my derived data a couple times but nothing worked.

What fixed it was opening a single file with xed i.e. I just did xed foo.swift and I was then able to open projects in Xcode.

You must log in to answer this question.