1

I have concerns about malware or something significantly affecting the performance of my iMac.

As you can see from the screen shot below I have updated to OS X Yosemite Version 10.10.5, but I did this after I started to have problems in the hope that any new security updates would help.

enter image description here

Additionally, I have installed Avast Mac Security and it hasn't identified anything.

Among my performance problems:

  • Applications can open very slowly.
  • Typing often has a very long lag before the letters or words appear on the screen.
  • Searches using Spotlight take ages.
  • Searches in Mail (which uses Spotlight?) take ages.
  • Clicking through folders in Finder can take ages for files to appear.

Very frustrating all of this.

I did have one of those MacKeeper things that locked up Safari one day but I've pretty thoroughly looked for evidence of it and can't find any.

Still, in the screenshot of my Activity Monitor below:

enter image description here

I consistently see the process, mds, seeming to command a ridiculous amount of CPU time. This doesn't seem normal to me.

I have additionally, cleared Spotlight's index by adding Macintosh HD to the Privacy list them removing it. I have further put just about every folder into the Privacy list except for Documents and Mail & Messages. In Spotlight's Search Results, I have unchecked everything except:

  • Documents
  • Folders
  • Mail & Messages
  • Contacts
  • Bookmarks & History

and I still have all of this mds activity?

One more additional symptom, that has me concerned. Some of my saved Safari information, like logins to innocent websites have disappeared. Not certain if this followed the MacKeeper yuck or after the update to OS X Yosemite Version 10.10.5.

Also, I do have Time Machine running. Not certain if the mds stuff has anything to do with it, but I even turned of Time Machine and I still saw all that mds activity.

Any suggestions about how to solve this problem or even how to analyze it much appreciated.

  • Roughly what files are shown by sudo fs_usage -f filesys | grep mds? This command shows what files mds (and related processes) are accessing, which should show which files are currently being indexed (mds is Spotlight indexing). Malware is extremely unlikely. – grg Dec 21 '15 at 16:54
  • @grgarside -- Running the command shows lots and lots of things, (and it keeps running) ,but what does this mean? What should I look for? What can this output tell me? – Jagra Dec 21 '15 at 17:33
  • Press ⌃C to stop the command so you can read it. There will be paths which should give you an idea of what it is indexing. For example, paths to files on your Time Machine drive shows that it is indexing Time Machine. – grg Dec 21 '15 at 17:35
2

Well, for starters, clearing Spotlight's index will make mds have to work all the harder to refill it.

If you've ever had MacKeeper on there, you need to get hold of Malwarebytes to get rid of the leftovers.

Avast, in itself, will slow down your machine. I tried it once, got rid of it within a week.

I'd also be tempted to say updating to El Capitan might fix some of it. I found Yosemite was getting pretty laggy towards the end. I even posted on here about one aspect of it - Typing lag on SE sites - Safari

  • But, I cleared the Spotlight index over a week ago. Shouldn't that give it plenty of time? I'll check out the rest of your suggestions. Thanks. – Jagra Dec 21 '15 at 17:00
  • 1
    Well, Malwarebytes found something called Spigot and removed it, but I still seem to have the problems. I've also uninstalled Avast. El Capitan seems like the next step... I'll keep you posted – Jagra Dec 21 '15 at 17:22
  • 1
    Update to El Capitan seems to have helped and may have solved the entire issue. You've got my vote for now. -- Thanks. – Jagra Dec 21 '15 at 19:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .