1

I have one of the new Apple Magic Keyboards. Magically, none of the function keys on the top of the keyboard, nor the fn key on the lower-left of the keyboard are responding when it's paired with my MacBook Pro (2012), running El Capitan. It works when paired with a different MacBook Pro, though.

Also, I had an older Apple wireless keyboard that suddenly started exhibiting the same behavior, which is what prompted me to buy this new one in the first place. So it looks like a software thing on this particular Mac. Any suggestions? I'm guessing I need to trash some keyboard prefs, but I'm not seeing anything that looks obvious in my ~/Library folder.

EDIT: Just adding that I tried in the Guest User account, and had the same issues. I then tried restarting in Safe Mode, and the keyboard worked fine, once I plugged it in via the Lightning Cable and paired it with the computer. So it's something borked on the system level, but again, I'm not sure what preference file to zap. Will keep looking!

  • You mean they work neither as F-Keys nor special function keys, whichever way you toggle the system pref? – Tetsujin Dec 21 '15 at 16:49
  • I mean they don't respond in either case - that is, they don't do anything when I press them, either as regular function keys, or as special function keys. Also, the fn key doesn't do anything (can't forward-delete, or double-tap the fn key to toggle dictation). – flysi3000 Dec 22 '15 at 5:01
1

Have you tried toggling the "Use function keys as standard F1, F2, F3 keys" option in the keyboard pane of System Preferences? Or try the Windows route and restart...

  • Yeah, tried both of those. I've actually been having this problem for a while now - several weeks, if not over a month. No issue with the built-in MacBook Pro keyboard, either. – flysi3000 Dec 22 '15 at 0:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .