0

I tried to properly eject a flash drive by moving it into Trash. It went up in that little puff of smoke. Now when I try to reuse the drive by plugging it back into the computer, it does not show up in my Finder. What gives? (I am running Yosemite.)

1
  • Did you tried to reboot ? – StrawHara Dec 21 '15 at 12:26
3

It sounds like you might have dragged it out of the Sidebar on your Finder Window. Try this: plug the drive back in, and then hit Cmd ⌘ Shift ⇧ C to go to your Computer view. You should see all your connected drives there; just drag the drive you want back to the Sidebar.

2
  • Cmd+C is copy? Just keep on doing Cmd+Up Arrow until you reach the top level and you'll see all the drives there. – user14492 Dec 21 '15 at 14:01
  • It's cmd/shift/c - I corrected it – Tetsujin Dec 21 '15 at 14:03
0

The little puff of smoke was the giveaway…

Next time, notice that in the sidebar, removable drives have a little up arrow.
Click that to eject.

enter image description here

Alternatively, select the drive itself & use Cmd ⌘ E
or right click in the drive's contents & select "Eject my SD Card"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .