20

I am using Mac OS X 10.9.5. Having Full Screen at the right end of the each window. How can i disable it?

I have tried th below workarounds to fix this but nothing worked out. I listed one of the workaround below.

Terminal

Type :

$ defaults write NSGlobalDomain NSAutomaticWindowAnimationsEnabled -bool NO

Hit enter

Close all applications before you do this to make sure the setting propagates. Any app running when you make this change will need to be restarted for the changes to take effect.

This is also i got from this forum. What can I do to disable full screen windows?

  • Setting the value of NSAutomaticWindowAnimationsEnabled has nothing to do with Full Screen view. It has to do with the window animation when a window is created, it starts as a smaller size and grows to its initial working size. – user3439894 Dec 21 '15 at 13:53
  • Any Solutions will be much appreciated.... – Venkat Dec 22 '15 at 6:18
  • From everything I've read on the Internet, what you're asking is not easily doable. In other words, there is not a simple defaults write command to stop a window from going into full screen view. What's the big deal anyway? Just don't click the full screen icon or press: ⌃⌘F – user3439894 Dec 22 '15 at 12:21
12

It's true there's no way to alter the default within OS X itself. Plenty of experts have tried, there have been detailed discussions at Stack Exchange and other sites, but there's no command you can run to turn full screen mode off, or change the default behavior.

Fortunately there are 2 ways to get around this…

  1. Hold down the Option (Alt) key on your keyboard when you click the green maximize button. The window will then zoom the OLD way - i.e., it will not go into full-screen mode.

    OR

  2. Use a free, third-party app called BetterTouchTool. Usually I don't like recommending specific software, but as far as everyone has been able to tell, it's the only app that actually lets you change the default behaviour of the maximize button - i.e., the only one that doesn't require any keystrokes at all. Instead, you use the app to assign a new action to that button. After that's set, when you click the button, it works the way it used to.

    You may need these instructions to change the app preferences. Their terminology is a little non-standard:

    In the BetterTouchTool Preferences:

    1. Select "Other" category at the top of the window.

    2. Make sure that "Global" is selected at the left side.

    3. Click "Configure New Trigger" button in the bottom part of the window.

    4. Select "Leftclick Green Window Button" as trigger.

    5. Select "Zoom Window Below Cursor" as predefined action.

    Save those changes and make sure to set the app to run automatically when you start your computer, so it is always running in the background.

    There may be other options in future, but last I looked the app was the overwhelming favorite fix.

Tens of thousands of people have written to Apple to complain about this over the past two years. And one of the reasons is: it tends to screw up and cause odd behavior with multiple non-Apple applications, i.e., ones that haven't updated their software to play nice with full screen mode. But even without that hassle, for many tasks (especially ones that require having multiple apps and windows open simultaneously) it's a frustrating time-waster for a whole lot of people.

6

The best way is to avoid clicking on that green button BUT instead double click anywhere on the title bar of the window.

  • Nice one. Why I never tried that is beyond me ha. – GeoffCoope Aug 2 '17 at 13:15
  • @GeoffCoope because it only works in some apps. – Bart Doe Mar 4 '18 at 7:31
1

What works for me - when i forget to option-click on the green button - is to move the cursor to the top so you can see the menu items and then click the green button.

I almost never want full screen.

1

Another possible solution is the application Right Zoom.

https://www.macupdate.com/app/mac/30591/right-zoom

I have used this app(maybe the name changed) since the Snow Leopard days.

It fixes my biggest grip/and frustrations with Mac OS having not a maximize equivalent to Windows.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .