4

I have recently purchased both a Dell 4K display (P2715Q) and a new Macbook (Retina, 12", 2015). According to Apple's website, the MacBook should be capable of driving the display at full resolution at 30 Hz, when connected over HDMI (via Apple's own USB-C to HDMI adapter), https://support.apple.com/en-us/HT202856. While the display is detected correctly and I can select up to the full 3840 x 2160 (though it defaults to 1920 x 1080) pixel settings, the Dell display continually flickers, going blank for a fraction of second every few seconds. This behavior persists regardless of the choice of scaling.

Has anyone else encountered this issue (or not) with this setup (or other 4K display)? Any strategy to resolve this issue?

Things I've tried:

  • Doing an NVRAM reset on the Mac (https://support.apple.com/en-us/HT204063, as suggested by Apple's help desk) and
  • a Factory Reset in the Dell monitor menu options (the only suggestion from Dell's help desk)

both of these appear to reduce or sometimes stop the flickering for a few hours, but it returns by the end of the day (or if the Mac is left on over night). Having to reset NVRAM every day isn't a great experience...

Edit the problem persists both while the laptop is in Clamshell mode (with the lid closed) or open as an additional monitor.

  • I’m assuming you actually mean a 13” Retina MacBook Pro, and not a MacBook Retina 12” ;-) – kenjikato Dec 29 '15 at 10:48
  • No, I really do mean the 12" Retina MacBook from 2015. This one: apple.com/macbook – cboettig Dec 29 '15 at 18:49
  • Got it, I guess I forget about that new guy since I’m a port hog users. ;-) – kenjikato Dec 29 '15 at 22:21
5
+50

This may be good or bad news deepening on how you look at it, but it’s the Dell 4K display, not your Mac. Both Dell model numbers 2715Q and 2815Q are notorious for this kind of flickering when used with MacBooks. If you search around on Amazon and other sites you will find similar complaints.

We purchased 4 of the Dell 4K P2715Q monitors where I work, and we returned ALL of them in the end because they exhibited this exact flickering behavior (as well as the inability to properly run at 60Hz).

It didn’t matter if we connected different types of Macs, or used different connectors. If we tried to drive these monitors at full resolution we saw this problem.

Dell told us the same thing when we called support (and we have the good support where I work), and we still never succeeded in making them work.

If you do find a solution with your Mac that makes this monitor work properly I will be happy to learn about it.

EDIT: For the benefit of anyone coming to this answer and wondering about other’s who’ve seen the same problem. Check out Apple’s forum posts reporting the same problems with the P2715Q.

  • Thanks for your answer, it is good to know this isn't unique to me. The P2715Q works perfectly with my Linux laptop, so I was surprised to find the Mac had issues. Usually it's the other way around ;-) – cboettig Dec 29 '15 at 18:47
  • Hmm, most reviews I see show no problems with Macs. This review suggests it does work with the new macbook 12" too: amazon.com/gp/customer-reviews/R103V0YZYUHP0F/… – cboettig Dec 29 '15 at 19:01
  • 1
    Based on some more investigation I just did, it sounds like this is a classic Dell supply chain issue. It depends on what electronics are in your P2715Q monitor, and how they synchronize with your computer. The problem sounds like it hits older version of the monitor than newer ones. So, if you have and older P2715Q that could be the problem. I know ours were some of the earlier ones, and I’m now assuming that’s where the problem came from. – kenjikato Dec 29 '15 at 23:15
  • 1
    As a side note, you can check out the review for the older P2815Q over at tested. tested.com/tech/pcs/459878-dude-dont-get-dell-4k-monitor You can also check out others one Apple’s support site that have had problems with the P2715Q here: discussions.apple.com/thread/6719572?tstart=0 – kenjikato Dec 29 '15 at 23:29
  • After upgrading from OS X 10.10 Yosemite to macOS 10.12 Sierra, I am having the same problem. With OS X 10.10, it worked fine. Thus, the OS might play a role as well. – Martin Nov 10 '16 at 17:49

You must log in to answer this question.

protected by Community Apr 17 '17 at 11:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .