1

I changed my Finder icon to give it a mustache by replacing the Finder icon .png file in /System/Library/CoreServices/Dock.app/Contents/Resources/ with the .png I made (same name). I cleared the icon cache (/private/var/folders/xl/2m4k1hnj70bbc2dz94sbl029pc_hk8/C/), and it worked, but some alerts still use the regular icon (some of the alerts use the mustache Finder I put in). Any idea on how to change this so all alerts use the mustache Finder? Thanks in advance!

  • You could try replacing the Finder.icns file located in /System/Library/CoreServices/Finder.app/Contents/Resources/Finder.icns, however I am not sure what it would change for. If the alerts with the normal icon come from non-apple apps, then you would have to edit the applications that make the alert – TheBro21 Dec 21 '15 at 0:43
  • I just tried that, and it didn't change anything so far as I could see. If I, for example, turn on Parental Controls and disable an app, this gives out two alerts. One says the application can't be opened, and the other says that I don't have permission to use the app. The former uses my icon, but the latter uses the regular one. – atirit Dec 21 '15 at 16:15

You must log in to answer this question.

Browse other questions tagged .