2

I have an iMac running El Capitan, an Intel NUC with Windows 10 and a Raspberry Pi running OpenELEC (for now, but I've also tried OSMC and Raspbmc). I have a simple WiFi network with no Windows domain or anything.

The Mac and the Pi can see each other in their network browsers, but not the NUC. The NUC's Network only shows the NUC. All of them are in the same workgroup (WORKGROUP) and all of them can ping each other. On the Mac, I can use Finder's 'Connect to Server...' option to add smb://10.0.0.199/sharename (which is the IP of the NUC) to access a share alright, and I can open \\10.0.0.99 on the NUC to access the Mac alright too. But the Windows computer(s) don't show icons for the Macs in the 'Network Neighborhood' equivalent and the Mac and Linux (Pi) computers don't show the Windows PCs.

Configuring networks and sharing on Windows has always been a trial-and-error process for me. Just mess with various settings till something works and that's how I've even gotten these machines to ping or access each other.

What am I doing wrong? Is there a guide to setting up a non-domain network the proper way with mixed platforms?

  • Have you scanned for internet devices ? – Lars Nielsen Dec 19 '15 at 8:43
0

You need to specifically enable Windows File Sharing on the Mac.
By default just checking 'File Sharing' will enable [I think, it's been a long time since I set up a raw machine] SMB & AFP, but not specifically Windows.

System Prefs > Sharing > Options…

enter image description here

If you need to specify a Workgroup, that's done from Network > Advanced… > WINS

enter image description here

One thing to be aware of is that if one of your non-Mac machines isn't set to be Master Browser, then the Mac can often force an election & win, even if it wasn't supposed to. Depending on which machine is most likely to be on at all times, you may need to force that to be the Local Master.

This is a good article on how to set it on multiple platforms - http://petestechblog.com/archives/847 - there's a bit much to précis here.

  • 1
    File Sharing is already enabled: the PC can access the Mac with //10.0.0.99! BTW You should intensify the scrambler. I can decypher Tetsujin and ... Law/Low as account names ;-) – klanomath Dec 19 '15 at 10:16
  • Well… one right, one wrong, but I take your point ;-) Will tweak – Tetsujin Dec 19 '15 at 10:19
  • 1
    I've always found that Windows doesn't see the Mac as 'advertised' on a Workgroup share if Windows-specific sharing isn;t enabled. Took me ages to get all the machines here speaking nicely to each other, but they do with that setup. – Tetsujin Dec 19 '15 at 10:24
  • I also had this fun at one point - superuser.com/questions/888923/… I haven't seen the same issue since El Capitan & Windows 10 – Tetsujin Dec 19 '15 at 10:25
  • File Sharing has already enabled on the Mac and all related sharing settings were also set up fine in Windows 10. Firewalls were off. The problem was a silly one... – aalaap Dec 19 '15 at 14:59
0

I fixed it.

The problem was a silly little one, which I so sure wasn't the case, I didn't even bother to look when I did think of it.

The NUC Subnet Mask was set to 255.0.0.0 for some reason. Everything else is using the default 255.255.255.0. Changing this back fixed everything.

EVERYTHING.

Everyone can see everyone!

EVERYTHING is working!

Thanks for all your help!

Update: I also updated to a new router with DD-WRT support, so things are even better now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .