6

enter image description here

What is this? copying and pasting this text into a text editor revealed perfect english. Why are they shown this way in Safari 9.0.2 on OS X 10.11.2

  • 4
    Looks like a font or cache issue. Try Fontbook > File > Restore Standard Fonts and if necessary do a Safe Boot. – Tom Gewecke Dec 19 '15 at 4:16
  • So neither restoring standard fonts nor a safe boot helped? – Tom Gewecke Dec 21 '15 at 19:52
  • 3
    What does the HTML source look like? – Kent Dec 22 '15 at 0:18
  • 1
    Safari - Settings - Show Develop Menu / On the page right click - Inspect element - click into the console - make Shit + CMD + C - aim the strange text and click on it - copy the html code from the console. – StrawHara Dec 22 '15 at 8:17
  • 1
    Do you see this problem on a specific site or every site on Safari? If this issue is related to a specific site, does Chrome render it without problems? – Behdad Dec 24 '15 at 19:32
5
+100

OS X builds cache files from the fonts installed on your system. Now and again these cache files can get corrupted.

Try running the following command in a Terminal window (you will be prompted for your password) and rebooting. This will remove these cache files; forcing OS X to re-generate them from scratch.

sudo atsutil databases -remove

From the atsutil man page:

databases
     will remove fontd System or User databases along with any cache
     files. Removing databases may cause the loss of font registration state:
     fonts activated outside the standard font directories, font faces dis-
     abled, and font libraries. New databases will be regenerated from fonts
     installed the standard font directories after the user logs out,
     restarts, or the fontd server is restarted.

databases [-remove | -removeUser]
    -remove remove fontd databases for active user and system (used when no
    one is logged in and some background processes).
    -removeUser remove fontd databases for the active user only.
0

I’ve seen this problem when there are corrupt or duplicate fonts on a system. As an alternative to @Alistair McMillan’s answer you can try this.

You can fix this problem by opening Font Book and trying one of two things.

  1. Try looking for duplicated fonts, and having Font Book fix them.

    Launch Font Book, and go to the Edit menu after it launches.
    Select Look for Enabled Duplicates...

    If it finds enabled duplicates you can choose to Auto Correct (which is what I suggest).

    enter image description here

  2. You can use Font Book to check for corrupted fonts.

    Launch Font Book, and select All Fonts from the Collection panel on the left.
    Then go to File menu and select Validate Font.

    This will run the font validater, and show fonts that have problems. If it does find problems, some of them can be fixed using the Font Validation window. Other problems might require you to uninstalled, and re-install a font to fix the problem.

enter image description here

If none of these work, then I would try the atsutil databases -remove suggested by @Alistair McMillan.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .