1

Air running Yosemite, played a video and turned on AirPlay mirroring to my Apple TV 4 running tvOS 9.1. The sound keeps coming from my Air, not the TV. I checked the Sound.prefPane and confirmed that the Apple TV is selected under Output. I've tried restarting the video as well as disconnecting and re-connecting AirPlay Mirroring, but the sound always comes out of the Air.

1

Found a solution on Apple forums, posting it here in case anyone else runs across this problem. I had to:

  1. Turn off AirPlay Mirroring
  2. Open Sound.prefPane and select Apple TV as the output
  3. Turn AirPlay Mirroring back on

For some reason it appears you have to manually set the sound output before connecting AirPlay Mirroring

Source

0

Before turning on AirPlay Mirroring go to Settings, Sound and choose Apple TV as output device. After this is done turn on AirPlay and choose Apple TV. If there is still no sound make sure the sound level is set high enough. On my MacbookPro, the sound was reset to lowest level after changing the sound output to Apple TV.

When finished with AirPlay, change sound output back to internal device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .