2

I can see a shared library and all of its contents but the contents do not load. When I try to watch a movie the loading/spinner icon stays for a very long while, until the screen saver appears. If the movie begins to load it will be 1/2 buffered the next morning.

All of this has worked for years, the library has been growing slowly the entire time. The movies do play (with no delay) on the mac-mini to which the media drive is connected and iTunes is running (no Home Sharing).

I recently fixed the file system on the disk on which the library resides (diskUtility "first aid" type of fix, using 3rd party software). The problem existed prior to the fixing and persists. All other access to the media drive has improved significantly since the fix.

I have tried to investigate my LAN, including shutting down everything else, to no avail.

All of the software and firmware are the latest versions.

Apple TV 3rd Gen.
Mac Mini early 2009.
Drobo 3rd Gen. external (media) drive.
Also all other iOS/OS X devices that can connect via Home Sharing including: iPhone 5c, 5s. iPad Air 2 and Apple TV 2nd Gen. MacBook Pros 2012 and 2007 (the libraries on these machines work just fine on all of the devices mentioned; they all have different content), MacBook Air 2015. And others.

You must log in to answer this question.

Browse other questions tagged .