1

I would like to receive any type of notifications (e.g.: WhatsApp message notifications) without vibration. I switched the vibration off under Settings → Sounds → Vibrate on silent, but now the phone calls do not vibrate anymore, and I therefore miss them while carrying in the jeans pocket for example.

Is there any way I can keep the vibration off while receiving notifications and keep it on while receiving calls with my device being in the silent mode?

iOS 9.2

1

Unfortunately, unless you jailbreak you iPhone, there's no way to do that. Turning off vibrations for notifications does that for all notifications, including Phone call vibrations.

0

Go to System Preferences --> Do Not Disturb. Activate it. This will make all the notifications silenced, vibrations included (note that, of course, notifications keep to be received, but silently).

Now, since you want instead to receive vibrations for incoming call, select Allow Calls From --> Everyone, in the same menu.

Your menu should be set as follows:

  • Just did it - no effect while calling, still silenced – Arthur Eirich Dec 18 '15 at 15:13
  • @Arthur Does your setting screen appear as in the pic? – mgiordi Dec 18 '15 at 15:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .