0

I have a 2007 MacBook Pro running Yosemite from an off the net upgrade from Snow Leopard and the graphics went crazy while trying to watch a TV program on my Slingbox app. I forced a shut down by holding the power button down and now it will not boot up to the hard drive. upon trying to start it up, the initial startup tone is sounded, the apple pops up on the screen and the progress bar begins to load. Upon reaching about half way on the progress bar it stops loading and eventually goes to a black screen with an arrow cursor. I tried reloading the OS with the original Snow Leopard OS disc but got a pop up stating that the OS was not compatible. I then went to utilities and ran a disc permissions test, a disc permissions repair , and then a disc test but the it said the disc appeared to be OK. It still will not boot and is still only loading about half of the loading start up bar. Anybody have any ideas? I think the hard drive may be toast but I really would love to load some of the pictures and desktop info on to an external drive but don't have a clue on how to proceed.

enter image description here

  • The above picture is the screen when opened in verbose mode – naz14 Dec 19 '15 at 2:01
0

Step one in proceeding is to start up in verbose mode (hold down Command-V) as you start your Mac, and then post the last few lines of output here. Sorry--I'd add this as a comment instead of an answer, but I don't have the reputation yet.

When you start up the Mac it should display text as it boots (white text on a black background). The last few messages may indicate the problem. See the example image below where I've highlighted an error in red. enter image description here

If the cause of the problem turns out to be a hard drive failure, I would recommend recovering as much data as you can from the hard drive. One way to do this is to connect your laptop to another Mac and boot the laptop into Firewire Target Disk Mode. Then use a data recovery program such as ddrescue to copy the data from your failing hard drive to a disk image on the Mac you're using for recovery. If you or a friend don't have another Mac with Firewire, you may be able to remove the hard drive from your laptop and plug it into another computer with a USB to SATA adapter. If you have more questions about ddrescue, it might be better to start a new question.

Keep in mind, that for some kinds of disk damage, the more you access the disk the more likely it is to fail completely. I just recovered 1.2 TB of my data from a 3 TB drive before it failed completely. Fortunately, all my data was in that first 1.2 TB.

  • Thanks but I don't understand what you mean by " then post the last few lines of output here". I you would explain I would very much appreciate it. – naz14 Dec 18 '15 at 15:02
  • By "posting" the lines, I really meant take a picture of the error and add it to your question. It's kinda tedious to re-type an entire error from Verbose Mode. – watkipet Dec 18 '15 at 23:24
  • Thanks for the info watkipet. I did start as instructed and found the most prevalent error to be "disk0s2: I/0 error". Would that point to a hard drive failure? I have a picture of the screen but don't know how to ad it to the comment. Your help is really appreciated – naz14 Dec 19 '15 at 1:52
1

It appears that your drive is failing. Your best bet is to attempt to clone the drive to prevent data loss. If you're unsure how to proceed, your next best bet is to run fsck, which can, in some cases, fix any formatting issues on the drive (but NOT physical ones). This Apple support article will give you a good walk through of the troubleshooting steps, but again, best to try to rescue data if you don't have a back up before going forward.

  • I did run fsck in what appeared to be a successful scan and repair but unfortunately, the drive will still NOT boot. Unless their is some magic trick to getting it to boot up one time, I guess (8) years of pictures, music, and technical data for my work is toast. Bummer!!! – naz14 Dec 21 '15 at 12:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .