My computer setup currently has three monitors: the 15.4" built-in display of my MacBook pro, a 27" Apple Thunderbolt Display connected by Thunderbolt, and a 10" Mimo Magic Touch display connected to the Thunderbolt Display via USB. The computer is running a version of OS X 10.10 Yosemite.

My computer also has a user agreement policy banner set to appear at login due to the presence of /Library/Security/PolicyBanner.rtfd. However, the Mimo monitor appears to be causing issues with the policy banner: namely, the banner is appearing partially off-screen, making the "Accept" button unclickable. I'm not sure if this is due to the smaller size of the monitor, or the atypical monitor/driver.

Furthermore, the standard accessibility functionality does not appear to work with the policy banner as far as I can tell: I can't use to tab to the "Accept" button, nor can I just hit . I've also tried various combinations of modifier keys with these options. +A (the first letter of the "Accept" button) also does not work.

Ultimately, my question is thus: is there a way to accept the policy without using the mouse and clicking on "Accept"? If not, this seems like an accessibility oversight on Apple's part, as I would imagine this is also a potential problem for users with special accessibility needs. It would also mean that you can no longer log into your mac with just a keyboard.

  • 2
    Possible duplicate of How can I activate buttons with just the keyboard? – Tetsujin Dec 17 '15 at 7:54
  • As the OP already has tried accessibility options and using modifier key shortcuts, I don't think this is a duplicate of the linked question. – nohillside Dec 17 '15 at 14:30
  • @Tetsujin: none of the solutions in the question you linked to work in this situation. ⌘+first_letter does not work, and full keyboard access to tab over to the button doesn't work either. Furthermore, full keyboard access appears to be a per-user setting, and this dialog appears prior to the login screen, so there's no user. – M. Justin Dec 17 '15 at 15:56

This appears to have been fixed in OS X 10.11 El Capitan, as the banner can be accepted using . Furthermore, the window appears fully on-screen in my scenario, rendering the need for a keyboard-only approach unnecessary for my use case.

So as far as I can tell, it is impossible to accept the policy banner without using the mouse in OS X 10.10 Yosemite, but they've fixed it in OS X 10.11 El Capitan.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .