2

I'm running El Capitan (10.11.2) and have had all sorts of problems with my USB-Serial cable after upgrading to El Capitan.

I have the latest drivers for my TrendNet TU-S9 USB-Serial Cable dated 11-10-2015. I've also tried getting the PL2303 drivers (dated 10-22-2015) from Prolific.

I unplugged the cable, uninstalled the old drivers per the instructions, rebooted, installed the latest drivers, rebooted, and plugged in the cable.

Under System Information-USB, I do see USB-Serial Controller D in the list of USB Devices. In /dev, I do not see tty.usbserial. Also, I do not see USB-Serial Controller as a possible interface in Network within the System Preferences. I just see Bluetooth PAN, FireWire, Ethernet and WiFi as possibilities when I try to add a new interface.

I've uninstalled and reinstalled several times and just can't get it to work. It is as if something is not letting the drivers be installed. I'd be grateful for any possible suggestions.

1

The aptly-named mac-usb-serial.com should be able to help you.

The real issue is conflicting drivers. In my experience, sudo kextunload AppleUSBFTDI has worked on both OS X 10.10 and 10.11, if you want to skip the linked troubleshooting steps (you should not).

| improve this answer | |
  • Thanks very much--unfortunately I went through all the troubleshooting steps at mac-usb-serial.com to no avail. When I tried sudo kextunload AppleUSBFTDI, I got the following message: Can't create AppleUSBFTDI. – DrJohnW Dec 19 '15 at 20:04
  • It the Apple FTDI driver may be named differently on your system. If you update the question with your version of OS X, model of Mac, and which exact FTDI chipset you're using, we may be of more help. – agentroadkill Dec 19 '15 at 20:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .