0

I'm on a MacBookPro8,1, Late 2011 and I'm running latest version of El Capitan with SIP disabled (if that matters at all)

@DavidAnderson I've been following the tutorial steps from @DavidAnderson posted here Boot camp install of Windows 7 issue, no bootable devices but I can't get the damn thing to work and as a new user here I'm not allowed to post in that thread :(

The only difference I have compared to the tutorial above is that my Disk Number is 2 instead of 1 in tutorial step 9.

After inputting the code from tutorial step 12 which is:

INPUT=$(printf  "f  $PARTITION\nw\ny\nq")
sudo  fdisk  -e  $DISK0  <<<"$INPUT"

I get an error:

Artists-MacBook-Pro:~ Artist$ INPUT=$(printf  "f  $PARTITION\nw\ny\nq")
Artists-MacBook-Pro:~ Artist$ sudo  fdisk  -e  $DISK0  <<<"$INPUT"
fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory
Enter 'help' for information
fdisk: 1> Partition 4 marked active.
fdisk:*1> Device could not be accessed exclusively.
A reboot will be needed for changes to take effect. OK? [n] Writing MBR at offset 0.

I'm assuming that's not supposed to happen? How do I proceed from here? I have kept going with the tutorial despite this error several times without success. The next error I get is at step 18.Error message

The full error is as follows:

Failed to open a session for the virtual machine BootCamp.

VD: error VERR_NOT_SUPPORTED opening image file '/Users/Artist/Documents/VirtualBox/bootcamp.vmdk' (VERR_NOT_SUPPORTED).

VD: error VERR_NOT_SUPPORTED opening image file '/Users/Artist/Documents/VirtualBox/bootcamp.vmdk' (VERR_NOT_SUPPORTED).

Failed to open image '/Users/Artist/Documents/VirtualBox/bootcamp.vmdk' in read-write mode (VERR_NOT_SUPPORTED).

Failed to attach driver below us! Not supported. (VERR_NOT_SUPPORTED).

AHCI: Failed to attach drive to Port0 (VERR_NOT_SUPPORTED).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Can anyone please help me? I've spent the last 3 days trying to install windows on this mac as I desperately need them and I've spent the last 5 hours on this tutorial alone without luck :( what am I doing wrong? I followed tutorial to the T but I must have missed something somewhere.

1

I believe you did not receive error executing Step 12. The output you posted is the expected result.

Four days after you posted your question, Tim Harper posted a comment where he had problems similar to yours at Step 18. He overcame this obstacle and succeeded installing Windows. His input led me to update Step 16. I hope this fixes your problem

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .