1

I'm trying to renew my Apple Push Notification Service certificate per the 30 day notification email I received. The email instructed me to visit http://identity.apple.com/pushcert to renew the certificate, but this page has not successfully loaded at any point I have tried. I'm not receiving a first byte from the server when attempting to load the URL.

It is rapidly approaching the 30 day deadline and I need to renew the certificate. Is there anywhere else I can go to renew the certificate or some way to fix the connection?

I've tried in Safari and Google Chrome, on two Wi-Fi networks, and just tried loading the page in Internet Explorer in Windows on a third network. I'm in the UK if there's any regional effect.

1

It's not loading for me either on my Mac in the US. However, if you request directly to https

If you need the non-https link to work or both are failing for you, I would perhaps try on a mobile network just to make sure it's not a routing issue between your ISP and Apple. Mobile safari should work to test the connection and it gives a more friendly user error message IMO.

Since you have an issue that's not covered, I would open an actual ticket with main support and ask them if you need to contact developer support instead for the push cert renewal.

  • 1
    Mobile network's a good idea, but unfortunately there's no difference. The page tries to load for ages until Safari says ‘the server stopped responding’. Apple's status page is as helpful as ever! I'll try contacting Apple support. (I'd +1 but I've reached vote limit) – grg Dec 14 '15 at 19:54
  • @grgarside Note the update, I didn't think to check explicitly https and not count on redirection / renegotiation last night. Hopefully you're able to get in to the site using the first link in the edited answer. – bmike Dec 15 '15 at 12:06
  • Interesting development! However the HTTPS page won't load either for me, this time with the message 'could not establish a secure connection to the server'. I'll have a more detailed look at this connection vs the HTTP one once I have access to a computer. – grg Dec 15 '15 at 17:43
  • @grgarside And now it's down for me too (both http and https) - both Mac and iOS safari. It seems the service is either being worked on, under DDOS, or perhaps at capacity for developers rushing to get builds and such in before the holiday cutoff/freeze point. – bmike Dec 15 '15 at 17:55
  • 1
    The HTTPS page worked and I was able to renew the certificate, thanks! The HTTP page still fails to redirect to HTTPS for me, but until that's fixed, this is a good workaround. – grg Dec 16 '15 at 19:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .