0

I've got two macs on my home network, both are enabled for Remote Login. From mac1 I open terminal and enter "ssh mac2.local". I am prompted for the password but the when I try the password I use everyday on mac2 I'm told that's the wrong password.

Is the password supposed to be some sort of RSA thingy? Is it not just my account login password? Where do I get the password?

thanks

2

Have you checked your System Preferences > Sharing to make sure that Remote Login is enabled and that your account is in the Allowed users list?

  • I had, but upon double checking I found the real problem. Thanks! – stackPusher Dec 14 '15 at 2:51
  • Is there a way to see and edit the allow users list from the command line? – Michael Aug 1 '17 at 22:20
1

Turns out I was using the wrong command. The correct command was ssh @, or in my case ssh mac2User@10.0.0.154. If you go to mac2's System Preferences > Sharing > Remote Login, it literally states the exact ssh command needed to ssh into that mac.

Note that Remote Login must be checked on mac2, as pointed out by Alphaman

As Alphaman also commented, the ip address can be replaced with mac2's machine name. Note that this may or may not be different than the username. The computers machine name can be seen on that same System Preferences > Sharing window

  • 4
    Is mac2 both the user and computer name? The username goes before the @, the hostname after. So, if they are both the same, then the following command should work: ssh mac2@mac2.local using Bonjour for name resolution (i.e., translating mac2.local into 10.0.0.154). Just a tip... – Alphaman Dec 14 '15 at 3:22
  • @Alphaman you are very correct, editing my post now – stackPusher Dec 15 '15 at 4:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .