1

At random times, my mouse cursor jumps to the top of the screen in the middle of the status bar for no reason at all. This used to happen on my previous install of El Capitan but stopped when I did a clean reinstall. Now the exact problem is happening again.

This seems to happen mostly when I am running in clamshell mode, connected to an external display while using my Magic Mouse. But this doesn't seem to be the issue since it resolved itself when I reinstalled.

I installed the Microsoft Office 2016 suite, Live Interior 3D Standard, Firefox, Skitch, and LaTeX recently. Could these be causing these issues? Is there any way to see "recently installed daemons" of some sort? New LaunchAgents, for example?

2

In my opinion, you should clean your Magic Mouse and your desk (dust, hair, ...). I don't think it is software-related.

  • Can you prove that a dirty Magic Mouse/desk would generate the effect that Mark describes? – user24601 Dec 14 '15 at 10:39
  • Personal observation. I have long hair and it happens often that one hair on the desk goes under the mouse and generate this kind of random behaviors. Remove the hair, and the problem disappear. – Slagt Dec 14 '15 at 11:17
  • Yes, same happened for me. I can confirm. Of course, this may not be the only reason but the simplest one. – Dmitry Dulepov Mar 6 '16 at 19:17
  • This is software related! for me it happens only when I connect my macbook to an external display. – Behzadsh Jun 28 '16 at 8:31
0

To fix this, if it's connected to an external display and has a closed lid, open (wait few sec) and close the laptop lid.

It sometimes happens on my MBP, it is too connected to an external display. Disconnecting all USB and turning off Bluetooth didn't help, so it's not related to an external USB/BT device.

My guess is that OS X El Capitan has a bug related to external display causing this. Another symptom is that sometimes app's window position are moved off-screen without apparent reason.

Looks like a bug in translation of screen coords with an external display connected.

  • Yes, this seems to be my use case. I've connected three different external USB mouses, one fresh from the wrapping, and confirmed that the jump-to-top happens particular when my external display is connected. (el cap 10.11.3 15D21) – frumbert Mar 4 '16 at 4:04
  • I have this bug from Mavericks. – Behzadsh Jun 28 '16 at 8:33
0

I had the same issue with my Macbook Pro. The trackpad is staying active even when laptop lid is closed. I toggled on an option to ignore built-in trackpad to correct this.

If you want an Applescript to do that for you check out my writeup on this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .