1

I've tried many different ways. I've gone to Text Message Forwarding and disconnected them. Nothing. I've tried going to Send & Receive and unchecked my phone number from my iPad and my iPad email from my phone. Nothing. I've gone so far as to switch off everything from the iCloud of my tablet. And still no solution. There's also this small tab that appears on my phone whenever I have Imessage opened on my iPad. And I want to get rid of it.

1

Settings > Messages > Turn off iMessage on your iPad.
That's it.

As long as you're signed in, you're going to get messages on both devices.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .