26

I am running Chrome 14 on OSX Lion.

I swipe 2 fingers horizontally to scroll a web page horizontally, for a page that is too wide.

When I swipe right, it works fine. When it swipe left it works for a second then I think it's trying to click on the browser's "back" button.

I'm not sure who's at fault, but there is some kind of conflict.

4
  • I think Chrome is trying to copy Safari's behavior, but doing a poor job of it. Try looking for something in the settings.
    – spudwaffle
    Aug 15, 2011 at 17:04
  • I disabled the back-foward gestures of Lion for now - it was making me nervous
    – nute
    Aug 15, 2011 at 19:36
  • Is v14 the beta channel of Chrome? What version is Chrome stable? Sep 14, 2011 at 23:46
  • Maybe you'll find my answer here useful in this case as well: apple.stackexchange.com/a/91236/49257
    – brafales
    May 13, 2013 at 8:41

6 Answers 6

27

You can disable chromes gestures by going to System Preference > Mouse OR Trackpad > More Gestures > and uncheck Swipe between pages.

I still love gestures so I downloaded BetterTouchTools which allows me to make the gestures I want. I disabled all apples gestures then created my own. You can get very custom with gestures this way. Or if you prefer, leave some of apples gestures on and use BetterTouchTools for the more custom ones.

Oh, BetterTouchTools is free :)

2
  • Thanks man, this helped me a lot, google chrome is not working properly on macbook pro mid 2015 for sweep between pages and this helped :)
    – Abude
    Jun 9, 2015 at 7:16
  • This did not work for me.
    – Igor Donin
    Apr 12, 2023 at 11:52
10

Turn off AppleEnableSwipeNavigateWithScrolls.

In your terminal, run this command:

defaults write com.google.Chrome AppleEnableSwipeNavigateWithScrolls -bool FALSE

Then quit Chrome if you have it running, re-launch it and tada, no more navigate-back-on-scroll-left.

If you ever need to turn it back on again, just set it to TRUE:

defaults write com.google.Chrome AppleEnableSwipeNavigateWithScrolls -bool TRUE

Picked this up over here.

1
  • 1
    This should be the accepted answer.
    – Igor Donin
    Apr 12, 2023 at 11:52
1

On Safari in Lion, the horizontal scroll and browser back gestures conflict, but a single swipe doesn't activate them both; left-swiping when there is room to scroll scrolls then stops at the edge of the page. Left-swiping when the content is already at the edge of the page triggers the back action. If Chrome behaves differently, I suspect the conflict is in Chrome.

1
1

If you don't have a problem changing your back and forth gestures, that will solve the problem. The real issue is that Chrome's back and forward gestures are a bit too sensitive at this point. They're still working on it because Apple switched it up on them and changed the gesture defaults in Lion. Back and Forward used to be three fingers (if I'm not mistaken) so they have to rewrite some things.

0

I realized that I installed TouchpadSwipe Chrome extension to get the back and forward page functionality on my other windows machine, and it synced to my mac chrome. Once I disabled that it went back to normal

0

I found a really quick fix, just open that exact page into a new tab. Boom, now you have both sides of the horizontal scrolling, because chrome doesn't have a page to go back to anymore

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .