2

After upgrading my iPhone to iOS 9.2 today, the songs in the Apple Music library don't show up as saved offline. Playlists show as offline.

I went to Settings->General->Storage and the Music app is using the same amount of storage as before (i.e. the music's still on the phone). But when I click on 'Music' in Storage, the Settings app freezes and doesn't recover even after minutes.

What are my options?

(I can of course redownload the library, but several gigabytes of my storage is already gone)

1
+50

My wife had a very similar problem, ever since upgrading to 9.0. I had to do the following in 9.2 to resolve her issues:

  1. Backup her iPhone.
  2. Wipe and restart her iPhone.
  3. Reload from her backup.
  4. Turn OFF iCloud Music.
  5. Turn ON iCloud Music, selecting "Merge" when warned about deleting or merging the current content on her iPhone.

She can now see and download any content in her library, and make anything she wants available for offline listening.

  • Thank you! I'm still looking for a non-destructive solution though. – thameera Dec 21 '15 at 15:59
  • I tried the same, and after many weeks of frustration, I took her iPhone to the Genius Bar; their recommendation was to wipe and reload, which finally worked. Good luck -- if you do find another way around it, I'd be extremely interested in hearing about it! – Alphaman Dec 23 '15 at 0:35
0

I went onto my songs on the iTunes app and played a song from there, it then let me access my music on my music app because it wasn't before I did that, it was just showing the girl listening to music on the screen. It's been like that since I downloaded iOS 9.2

0

I had the same problem. This is how I solved it:

Settings>Music

Turn off "Show Apple Music"

Then go back to iTunes. The picture with a girl will now have text underneath. One of the lines is "go back to my music"

Tap on that sentence. Now you will be back to your music.

  • 1
    Didn't solve for me. – thameera Dec 27 '15 at 7:57
-1

Here's how I solved this:

  1. Go to "Configuration/Settings"
  2. Select "Music"
  3. Tap on the option "Join Apple Music"

That's it, with that option the Music App pops up directly in your local music files.

I think the problem is with the splash screen (the one with the girl with headphones), but with the "Join Apple Music" option that screen don't show, so, the app opens with no problems.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .