13

So after brew doctorI`ll get the following without any recommendation:

Warning: You have external commands with conflicting names.

Found command `brew-cask` in following places:
/usr/local/bin/brew-cask
/usr/local/Library/Taps/caskroom/homebrew-cask/cmd/brew-cask.rb

Is there a way to settle that conflict?

3
  • Since cask runs on top of brew - did you run the recommended cleanup tools? It's probably not going to solve things, but it might help isolate the issue to brew or cask: brew update ; brew cleanup ; brew cask cleanup - Also - could you list one cask you use so we can try replicating your setup?
    – bmike
    Dec 10 '15 at 14:41
  • For the first time I'll get the following when running clean up tools: Warning: Skipping czmq: most recent version 3.0.2_3 not installed Warning: Skipping git: most recent version 2.6.4 not installed Warning: Skipping libsodium: most recent version 1.0.7 not installed Warning: Skipping node: most recent version 5.2.0 not installed
    – Mamba
    Dec 10 '15 at 14:57
  • I got the node warning - so I just brew rm those packages and will let them install next time I need them. I think a cleanup / migration step was added recently, but can't speak for certain on that yet without more digging. For now, I'm happy to have a clean cleanup run.
    – bmike
    Dec 10 '15 at 15:09
6

I don't use casks much, but on my test machine I just tapped the cask infrastructure to see what it installs today. I have the brew-cask.rb file and not the one in /usr/local/bin

If you have a backup system, back up and then delete /usr/local/bin/brew-cask and rerun brew doctor. You could also rename the file if you don't want to hassle with backups.

mv /usr/local/bin/brew-cask /usr/local/bin/ZZdeleteZZbrew-cask
brew doctor

That way a program or script calling the tool won't see the file (or sym link) in /usr/local/bin. You could then test things a bit and clean up the file in question. It also is easier to fix if my hunch that the one in bin is needed somewhere and the tool is wrong to complain about both.

Additionally, there looks like a change was made somewhat recently to cask/brew integration:

My uninstall steps were different than the ones linked above since I installed cask today and not from before. My results might not match yours in that case :(

3
  • I'll moved it and Your system is ready to brew
    – Mamba
    Dec 10 '15 at 15:00
  • But the upper Warnings after clean up remains
    – Mamba
    Dec 10 '15 at 15:02
  • @HiThere Yeah - I'm not always so hot to fix a brew doctor warning until I have an actual downstream error. Yes - they often can cause issues, but brew itself is so large - not everyone builds from source and not everyone uses casks at all. Some people only come for the casks. Please ping me if you have an error with a specific package install. I'm trying to learn more how the brews work, so I'm up for real problems to help troubleshoot and possibly solve.
    – bmike
    Dec 10 '15 at 15:08
20

Important December update (from https://github.com/caskroom/homebrew-cask):

Homebrew-Cask will now be kept up to date together with Homebrew.

If you haven’t yet, to switch to the new system, run:

brew uninstall --force brew-cask; brew update 
1
  • This solved it for me. Thanks! Nice of you to post that command so that I didn't have to fish it out. Jan 30 '16 at 8:57
5

You could also remove the cask additions and see if the clean up script removes the remnants:

brew uninstall --force brew-cask

At that point, you can re-run the installation according to the current instructions:

brew tap caskroom/cask

Just the uninstall alone solved your issue for me when I ran across it.

3
1

I faced this exact warning today. For me, simple brew update && brew upgrade && brew doctor worked.

Got finally, the satisfying Your system is ready to brew log.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .