0

I've just been asked by the wife why her iPhone 5s (iOS 9.1) is not connecting to the wifi. I've just checked the router and it shows that her phone is connected and given an IP address, however it still shows 3G.

Things I've tried.

  1. Turn her phone into airplane mode and not.
  2. Reboot the router.
  3. Repeat step 1.
  4. Restart the phone.

I know the phone is connecting to wifi because when I disconnect the phone it disappears from the connected devices list and when I connect again it shows up again. It also shows up in the phones settings menu with a blue tick next to our wifi connection.

Any Ideas?

Mark

  • Take things to a slightly higher level: Double-click the Home button and swipe closed all open apps, then do a hard reset (Home button/power button simultaneously until screen turns black,) then power it back on. Next, check Settings > Wi-Fi then tap the info-circle on the Wi-Fi network you usually connect to and tap Forget This Network. Lastly, reconnect to the Wi-Fi network. (Note: If you've done any of these steps already, please add them to your question for others to read.) – IconDaemon Dec 9 '15 at 22:58
  • Thanks for the advice. Try this and I suspect this is what fixed it, but it didn't take affect until a restart. – Mark Johnson Dec 10 '15 at 19:35
2

The latest ios9 has a wifi assist feature. If the phone thinks you're on a lousy wifi connection it will failover to cellular data. I've turned mine off.

Settings > Cellular > Wi-Fi Assist

See https://support.apple.com/en-us/HT205296

  • It does have WiFi assist enabled. But it is not changing its icon to wifi. Just shows 3G. Do you know if this is what the phone shows when using the wifi assist feature. – Mark Johnson Dec 9 '15 at 22:53
  • @MarkJohnson Have you disabled it. – bs677 Dec 9 '15 at 22:57
  • Yes we have disabled it. We have also forgotten the network and re added it and we are still experiencing this problem. – Mark Johnson Dec 10 '15 at 19:30
  • Just turned the phone off and on again and it's now connected properly to WiFi. WiFi assist is currently off. Thanks for your help. – Mark Johnson Dec 10 '15 at 19:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .