3

Before when I entered localhost into the browser there was my localhost from MAMP, basically directory for my web repositories. Recently I installed OS X Server, and now when I enter localhost into the browser there is:

enter image description here

How to disable OS X Server and bring back to my MAMP localhost?

In OS X Server everything is turned off:

enter image description here

  • 1
    Did you try to turn of the website(*) in the OS X Server app? *I'm not sure if website is the correct name – Jules Dec 9 '15 at 12:44
  • turn on or off? – Bartłomiej Semańczyk Dec 9 '15 at 12:48
  • Off. Can't change my first comment – Jules Dec 9 '15 at 12:59
  • Everything is turned off... what else can I do? – Bartłomiej Semańczyk Dec 9 '15 at 13:06
1

You need to turn off the Webserver from OS X Server's Server Admin. In fact, if you are not planning to use it, I would recommend shutting down all the services from Server Admin

  • But everything is turned off in OS X Server. – Bartłomiej Semańczyk Dec 9 '15 at 13:04
  • 1
    Oh, then check for if any services are still on under System Preferences->Sharing and disable them. – sdayal Dec 9 '15 at 13:08
  • Yes, it helped:) there was turned on Remote Login. – Bartłomiej Semańczyk Dec 9 '15 at 13:11
1

There are actually two things you could do.

Option 1 You can edit your host file and so localhost won't be used by OS X server anymore. How to edit your host file is explained in this link.

Option 2 I prefer this option, which is available in MAMP PRO. I'm not sure if it is available in the free version of MAMP.

When you open MAMP, click on the host tab. You will now see this screen: Screenshot of MAMP PRO - Hosts You can than change the server name and start/restart you services to apply the changes. In the screenshot above, I can access my website

http://localhost/ and http://website/

I hope this will solve your problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .