1

I am having a problem with the battery in my Mom's old iPhone 4.

She recently had to replace her phone because it was showing this screen: enter image description here That isn't her phone, but that is what it was showing. When we unplugged it, the phone completely died so we left it to charge for a while.

It then showed the connect to iTunes screen:

enter image description here (Also not her phone)

I went to unplug it and plug it into my computer, but it instantly turned off. I plugged it into the computer and when it started, it showed the same screen. iTunes found it and said that I needed to update or restore the phone. I tried, but I got error 21 (some online researched said that this meant the OS couldn't boot because it had a bad battery). I ordered a new battery online and attempted to replace the battery myself. I had no problem and when I was done and plugged it in to the computer, it showed the same screen. I should also mention that there was never (from the start!) a screen that indicated that the battery was dead.

At this point I was pretty upset because my mom had years and years of photos that were never backed up.

Any help would be very much appreciated.

EDIT: My questions are A) Why would the iPhone allegedly not detect the battery B) are there any fixes that would not require me to take the device in (not on warranty anymore) and C) If it isn't the battery (because I have replaced it), what could be causing this?

  • What is your question? – RedEagle2000 Dec 9 '15 at 2:35
  • @RedEagle2000 why won't it A) detect the battery (old or new) and B) what would some other problems be?? – KennethDev Dec 9 '15 at 2:37
  • Welcome to Ask Different. Generally we close questions that have multiple a/b/c - but in your case, this looks to be a problem with the control board and not the battery (or the battery problems at least aren't interfering with the backup options) – bmike Dec 9 '15 at 3:00
1

That's not a battery problem unless it powers off while you are trying to connect it to a computer / powered USB hub to try and pack up the photos.

Taking it to Apple for service won't get the data back as they erase the device if it gets swapped. If the battery indicator is not showing, it could be a bad battery (even some new parts are DOA), the connectors failing or the control circuitry on the main board is faulty.

Worst case, get a quote from a data recovery service and understand if they charge if they cannot get back what you want. Be careful - some say if any data is recovered - be sure to specify you only want photos if that's what you're considering paying for.

If you have a Mac - check out PhoneView to restore the photos. There are lots of other apps, you can search them here for specifics but you might have passed the window where you can get the photos back.

  • I tried PhoneView and it rebooted into recovery from dfu after starting the process. I put it back in dfu and the same thing happened. I think the device has been wiped. Thanks for the help. – KennethDev Dec 9 '15 at 14:38
  • @KennethDev DFU is the wrong mode to transfer files - in fact, doing that could have made things worse. That only lets you wipe. You would need the device booted in non-DFU, so perhaps try powering it off and just connecting it to a charger and see if it can get a normal start. – bmike Dec 9 '15 at 20:20
  • The application instructed me to do so (advanced mode) and I tried without doing it before. – KennethDev Dec 9 '15 at 22:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .