6

After updating my MacBook Pro to 10.11.2, I am having huge issues with iCloud. Thus far, I am noticing that:

  1. I can no longer use Messages.

enter image description here

  1. I cannot use FaceTime.

enter image description here

  1. I cannot authenticate into iCloud via the Preference Pane.

I have verified my iCloud credentials elsewhere (on another Mac, on iCloud.com, on an iOS device).

Does anyone know how I can force iCloud to recognize my credentials on this machine?

EDIT: In response to the myriad suggestions by Tetsujin, I have catalogued them here:

  1. NVRAM reset has been done.
  2. Started up MacBook in Safe Mode.
  3. CANNOT use Messages from Safe Mode.
  4. Checked status of service (UP).
  5. Signed out of Messages and Facetime on all devices and back in.
  6. Restarted routers and incoming internet.
  7. Tried alternate ISP.
  8. Verified SN displays, and is valid.
  9. Disabled all firewalls.
  10. Checked veracity of /private/etc/hosts file.
  11. Verified that no proxy was being used.
  12. Deleted Keychain entries for imessage and com.apple.idms.
  13. Verified that the Guest account CAN access Messages.
  14. Deleted com.apple.apsd.plist and rebooted.
  15. Reset SMC.
  16. Reinstalled OS X 10.11.2.

None of these things has worked for me.

EDIT 2: I am also having issues running apps purchased via the AppStore. Each time I run one, I have to log into the AppStore to verify the purchase.

EDIT 3: I've done myriad changes including deletes of Caches, StartupItems, Libraries, etc. (in concert with AppleCare Support), and nothing has remediated the issue so far. I'll document everything as time permits.

EDIT 4: The issue is more than just with iCloud, but also involves certain apps that require access to some subfolders in ~/Library. For example, when I try to update EFI's Fiery Software, I get this:

enter image description here

And when I execute OmniFocus, I see this response:

enter image description here

And some apps that use the Sparkle framework to perform updates simply fail. iSale 5 is one example:

enter image description here

Some apps work fine, while others obviously do not. There is a major permissions issue here somewhere. I just haven't been able to track it down.

  • try my fix at apple.stackexchange.com/a/205322/85275 & also see Linc Davis's comprehensive post at discussions.apple.com/thread/7272123 – Tetsujin Dec 9 '15 at 8:15
  • Ouch, Dave - [sorry, saw point 14 late, earlier comment reduced to just 'ouch'] – Tetsujin Dec 9 '15 at 19:22
  • Tell me about it. I'm reluctant to let my staff implement El Cap because of these issues. This train wreck of an OS update has crippled my productivity and then some. – Dave Dec 9 '15 at 19:25
  • I feel for you really. I had several days of flapping around before I got mine going, including [for the first time ever] nuke & pave options, with little joy. I'm tempted to say my eventual fix was just voodoo, shake the chicken bones whilst facing the right direction on a given Tuesday. Once I did get it fixed, though, El Cap has been no more of an issue than any other major update. I'd be tempted to give Apple a ring, they're usually pretty helpful. – Tetsujin Dec 9 '15 at 19:29
  • I have several other minor issues as well, like Sparkle updates no longer working, constant password requirements in Finder, etc. Things that are mainly annoyances. But I live by Messages, and iCloud. If nothing else, I'll start over again from scratch, but I'm holding out for a solution for now. – Dave Dec 9 '15 at 19:31
6

It seems that I have found the answer to this issue. I ran the ACL permissions repair tool at the Terminal in Recovery Mode, but when I checked the ~/Library and its subfolders from the CLI, I found that many of the subfolders were owned by another user account. (How this happened is anyone's guess.) The solution here was to Get Info for the ~/Library folder, and then ensured that I had RW access to it. Then, I simply chose to Apply to Enclosed Items...

enter image description here

  • 3
    Glad you got there in the end… looks like you'll have to pay yourself the bounty :) – Tetsujin Dec 15 '15 at 15:18
  • Unfortunately, you can't do that anymore! :-) Otherwise, I would. – Dave Dec 17 '15 at 22:39
0

Try restarting your Mac. If that doesn't solve your problem, go to the iCloud pane in System Preferences and try signing out and then back in.

  • Did those things. Didn't work. Thanks for the suggestions though. – Dave Dec 9 '15 at 3:00
0

Dave...I had the same problem and here is what worked for me. I updated from 10.11.1 to 10.11.2 (Vanilla install with Clover). Use iMessage_Debug 2 to get the proper info in conjunction with steps in the screenshot. iMessage_Debug 2:enter image description here http://www.insanelymac.com/forum/files/file/278-imessage-debug/

  • I am now up and running as of 12/1215 at 16:53. – Derwood Dec 12 '15 at 21:53
0

I had the same issue with iCloud, but also had wifi troubles when connecting to a WPA2-Enterprise network. The only way for me to fix is was doing a Clean install from an external disk. Using the recovery mode to erease the disk and reinstall os x did not work.

If you want to reinstall your mac, make a backup first, but do not put the while backup back because the problem then reoccurred (in my case).

If you do not have a external disk with os x, you could go to an apple store or apple certified service center.

0

Just solved the identical symptoms - thought it was el Capitan because the service stopped working the same day I ran the 10.11.3 upgrade, but in fact LittleSnitch was blocking identityservicesd from contacting IMRemoteURLConnectionAgent. As soon as I deleted the rule all was happy.

I would assume that any firewall could be doing the same thing. I was alerted to the issue when I followed instructions elsewhere to create a new iCloud account and create a new Admin User on the iMac using that account to log in, and it wouldn't connect.

  • I thought about that, as I have used Hands Off, and Little Snitch in the past, but neither were installed on my device at the time. Fortunately, for me, this time around, 10.11.3 did not cause the same pain as 10.11.2 did. – Dave Feb 4 '16 at 16:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .