Have an issue with Macbook Air 13 (Mid 2013). Both trackpad and keyboard work fine on the boot screen, also in Windows 10 bootcamp installation, but in Mac OS X neither works (not even Caps Lock LED). External keyboards and mouses work fine.

Tried clean re-install wiping all existing partitions (Yosemite and El. Capitan) - no difference. Actually, even during Mac OS installation, input works fine on the boot screen, but as soon as Mac OS setup loads, both keyboard and trackpad stop working.

SMC and PRAM resets didn’t help.

EDIT - Some additional info gathered during troubleshooting: (Thanks Tiago Ferreira)

  • Internal keyboard and trackpad work fine in Diagnostics Mode.
  • The only warning on Diagnostics page is that battery needs servicing.
  • Keyboard and trackpad do not work in Safe and Single User modes.
  • When booting into Single User mode, there are bunch of errors related to AppleHSSPIController
  • Disabling Bluetooth doesn't help. Apple Bluetooth mouse works fine.
  • EFI and SMC Firmwares are up to date.

I strongly suspect it must be a hardware issue, but why it works in Windows and in certain Mac OS boot modes?

  • 1
    Can you enter recovery mode? Did you restore from backup? Have you tried if an external mouse or keyboard work? Have you tried with a different account? Tiferrei Commented Dec 8, 2015 at 16:14
  • 1
    Hum, interesting... what's the output of: kextstat -kl | awk ' !/apple/ { print $6 }' in terminal? Is mouse keys in Accessibility off? Commented Dec 8, 2015 at 16:43
  • 1
    OK, just to set the scene, how is your mac now? OS version, blank user, setup, restored backup? Commented Dec 8, 2015 at 17:30
  • 1
    Hum it is quite strange indeed. Have you tried a diagnostic? Make sure your mac is connected to it's charger and hold D on startup. Commented Dec 8, 2015 at 18:03
  • 1
    So now we know ok it's working, the problem is not on your disk but precisely on the main graphical part of the OS, have you tried accessing single user mode? Did the keyboard work? How did you reinstall the system? The problem may be in a faulty installer Commented Dec 9, 2015 at 15:38

1 Answer 1


So my final answer is that this is probably a firmware problem and you need to re-flash it, unfortunately Apple doesn't allows users to do this on Macbook Airs. You'll need to take it to your local Apple Store for the genius to do it. If it is indeed an hardware problem, Apple Stores have access to a more detailed system diagnosis, which will almost certainly tell you what the problem is if it isn't firmware.

Sorry for the long time and hope you can solve it.


  • No problem! Hope you solve it mate. Commented Dec 10, 2015 at 13:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .