1

I'm tunneling over ssh with this command (under El Captain)

ssh -D port_number -N -C myusername@server.url

and enable foxyproxy on the browser. Everything seems to work just fine on the browser. However, on the terminal I keep getting messages of the form

channel X: open failed: administratively prohibited: open failed

for various channel numbers. I set Tunnel yes in /etc/ssh_config but that did not do anything. I repeat, things work despite the error messages.

0

Again. many things mixed up together. What are you trying to achieve? There are few things wrong, in your post:

  • Tunnel option in ssh_config does not do anything related to the SOCKS5 Proxy, which is the command you are describing. It is related to VPN and "ethernet" (layer 2) tunnelling, which is initiated by -w option

  • Port forwarding and SOCKS5 proxy (-D) is allowed by option AllowTcpForwarding in sshd_config on the server!

  • If you would really want to user layer 2, forwarding, you need root login on the remote server.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .