1

Whenever I click on a full address in a text box in Safari, it is auto-recognized and pops up a map, like in the following screenshot:

enter image description here

Is there any way to disable this? This does not happen in Chrome.

It seems like it's most text fields: google.be, yahoo.com, apple.com, even the text field in the w3schools example.

My system info is as follows:

  • OS X El Capitan 10.11.1 (The laptop originally shipped with Yosemite)
  • Safari 9.0.1
  • The only extension in Safari is Lastpass (password manager). I've tried disabling Lastpass and the popup still comes up.
  • Which version of OS X are you using? Do you have any Add-Ons? – Gabkano Dec 7 '15 at 10:50
  • Updated to include system / safari version. – jchu Dec 8 '15 at 0:47
  • Any chance you can provide a sample link? I can't find any instance in Safari where clicking on an address would open a map. I'm curious to see exactly what you are clicking on. – Charlie74 Dec 8 '15 at 2:20
  • When I enter the address into the search field for Google.be or nl.search.yahoo.com or the address field in Gmail contacts. Strangely, when I enter an address in Bing, it's unaffected. I then click on any of the letters of the address in the text field. – jchu Dec 8 '15 at 15:44
  • I was curious to see whether it's something specific websites were doing with their input field, but even when I enter an address in this w3schools example on html input fields, I get it as well. – jchu Dec 8 '15 at 15:48
2

This is almost definitely caused by a setting in your system preferences: enter image description here Maybe you have the new trackpad (or a macbook) in which case this part of the system preferences might look a little different, i know trackpads/laptops with 3d touch probably have some variation in regards to the appearance of the trackpad preferences, but it must be a setting thats analogous to the setting near the top left in the above picture, 'look up & data detectors'.

To me this would suggest one of 3 things:

  1. You're accidentally clicking the "shortcut" you assigned to 'look up' when you're intending to hit the shortcut assigned to 'click'

  2. Your trackpad is defective/worn-out and thats why its doing this.

  3. You have 'look up' and 'click' assigned to the same shortcut. (which doesn't seem to be possible on my computer)

  4. You've been 'clicking' everything using 'look up' (not sure thats possible either).

An easy solution to this is to simply disable any "mouse shortcut" for 'look up'. You can still access look up by right clicking.

For anyone who just wants to see whats happening with their own eyes (I know I was pretty curious):

if anyone on a mac highlights all of

30 rockefeller plaza new york ny

(or any address) and right clicks it, then selects

Look Up "30 rockefeller plaza new..."

then they'll see the same pop up.

  • Thank you!! Disabling "Look up & data detectors" stopped this from happening. I suspect that this may be a hardware issue, as I didn't even know that I had a force click on my trackpad (and I have not been pressing hard enough to engage it). Out of curiosity, where do you set shortcuts for the trackpad click? – jchu Dec 8 '15 at 18:32
  • Ive never used a trackpad with 3D touch, but i assume it can still actually (and audibly) "click", and if thats correct, and if your trackpad settings page is similar to mine, then there are two ways to click, and you switch between them by checking and unchecking the box in the bottom left of the picture i uploaded. Infact, that particular setting would imply that regardless of whether the "tap the click" option is enabled, you can still click via the method in which you firmly press until you feel a click and hear an audible clicking noise (from the mechanism itself not a sound effect) – pau Dec 8 '15 at 20:06
  • Yes to all of your statements. As an fyi, I'm using a 2015 Macbook Pro. I hear an audible lighter click for a regular click and the louder click for the force click. (This remains the case if I turn on "Tap to click" You then can additionally also tap to click). And the settings window is exactly like the one in your photo, except with a different video. – jchu Dec 8 '15 at 21:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .