0

I have a 15 inch mid 2015 MacBook Pro Retina with El Captian on it. I recently installed VMware Fusion Pro in that and created a new VM and installed Windows 10 64Bit. The problem I'm having is that the resolution is very bad when I use to this Win 10 in my VM. The texts are blurry.

My Mac's resolution is 2880*1800 (Intel Iris Pro graphics) and i thought if i change my Windows resolution to the same values, it would fix it. But I can't even see that kind of resolution in my Windows display options.

enter image description here

You can see the blurriness in the text Identity and Detect. (I tried different resolutions and ended up with the setting 1440*900. I also adjusted the text size to be 125%)

How do I fix my resolution issue so that my Windows 10 is also sharp. Is it a problem where Windows 10 is not capable of supporting Retina displays ?

Here is another screenshot of what I am having. The left side is chrome in my Mac and right side is Chrome in my Windows 10.

enter image description here

2

Finally I got this working. The trick was to install VMware Tools in my VM OS (Windows 10). After installing this, I was able to select 2880*1800 resolution.

Much better now :) Some apps are still not sharp (Visual Studio menu items etc.). But I can live with those.

enter image description here

1

I already had VMware Tools installed, so when I went to Install, it took me down the "Change" path and I didn't have anything to change.

What worked for me was:

  1. Repair VMware Tools (Windows restart required afterwards).
  2. Unchecking "Use Full Screen Resolution for Retina Display" (which I had checked before).

Now it looks much better, and it fills the entire screen again.

0

Load and start the virtual machine. In the menu bar Click 'Virtual Machine' then 'Install VM Tools' or 'Reinstall VM Tools' click install/repair and restart virtual machine. This should work - took me a couple of hours to find the solution.

0

my solution was to disable the 'Use full resolution for Retina display"

  1. Virtual Machine
  2. Settings
  3. Display
  4. Use full resolution for Retina Display (un-check)
0

On my 2017 MBP 15" I needed to also uninstall VMWare tools from my Win 10 VM and reinstall it. Doing the Repair was insufficient. During the reinstall I checked Complete instead of Typical. Finally got full resolution back in Win 10.

0

All my virtual machines (with GNOME, KDE, WIN10, etc) seem to be a bit blurry on VMWare Fusion (comparing to non-VM or VMWare Workstation VMs).

This is what worked for me (on a 2018 Mac Mini and VMWare Fusion 11):

  • In VMWare Fusion, enable "Use full resolution for Retina Display" under Display
  • On Mac, open "System Preferences", make sure that Resolution is "Default for display". (I personally prefer "Scaled" display but it looks like it does not play well with VMWare Fusion).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .