I'm not able to properly set icons, I've tried with *.icns and *.pngs.

I'm on a El Capitan, MacBook Pro (Retina, 13-inch, Early 2015)

Does this seem familiar to anyone?

enter image description here

EDIT: I should mention I don't want to disable any security

  • You are supposed to copy and paste the actual picture of the icon not drag and drop the file there. – user3439894 Dec 6 '15 at 12:07
  • You can actually do both (or in my case, can't actually do either :P ) – AshCooman Dec 6 '15 at 15:22

Try opening the icon in Safari then dragging it from there.

Dragging the image from Safari

  • I'm very surprised but it worked perfectly. – AshCooman Dec 7 '15 at 14:27
  • Glad to hear. I remembered having this problem back in 10.6 so it's definitely not something new! – Jacob Wood Dec 7 '15 at 15:09

Try changing the icon using Liteicon.

It's a simple application solely able to change icons for applications and some system icons. And if you are changing icons for several applications it should be a simpler and faster way to do it.

  • Unfortunately Liteicon doesn't play well with El Capitan :( github.com/tinalatif/flat.icns/issues/216 – AshCooman Dec 6 '15 at 15:20
  • 1
    The problem you're linking too only applies to system apps - which the app in your example (Spotify) isn't - so that should work for you. – ssssaaaa Dec 6 '15 at 15:42
  • 1
    Ok, I guess its an option. For me personally I'm looking for a fix to OSX rather than an app as its just a single icon I want to change. But thanks for the suggestion. – AshCooman Dec 6 '15 at 15:44
  • 1
    However if you are trying to change system apps icons I don't believe that can be done anymore (neither manually or with Liteicon) because of the new security settings referenced in your github link. – ssssaaaa Dec 6 '15 at 15:45
  • Yeah sounds like this is just a bug. Oh well. – AshCooman Dec 6 '15 at 15:45

In El Capitain you have to: 1. Open the "new" image you want to set as folder icon on Preview 2. Select the image from the window 3. Copy/Paste in the Get Info folder Icon Worked for me :)enter image description here

  • This method is analogous to clicking and dragging an image on the Get Info icon (which should also work for you). Unfortunately on my system, this does not work. – AshCooman Dec 7 '15 at 10:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .