5

I'm running OS X 10.11 El Capitan and Screen Sharing has become more and more tedious. I have a MacBook Air, my usual laptop, and a Mac mini to which I want to connect with Screen Sharing (on my MacBook Air).

However, most of the time I cannot see anything on the Sidebar of the Finder on my MacBook Air. If I manually Go → Connect to Server and enter vnc://myhomemini (which is the server that my Mac mini's Sharing settings suggests I use), I just the popup message:

Unable to resolve “myhomemini”
Verify the name you entered and make sure your network connection is working.

Neither computer has a firewall enabled. Both are on the same home network that belongs to me, of course, and both are online without issues individually. On the Mac mini (destination computer, whose screen I want to see on the MacBook Air), the Sharing settings have both Screen Sharing and File Sharing enabled. Nothing else like Remote Management etc is enabled.

What else? Apple's support website is utterly useless. All the advice on the Internet is also speaking of random things from 2012, etc. Welcome any ideas.

  • Interesting. If I enable screensharing it says vnc://192.168.x.x or by looking for ThatMac in the Finder sidebar. It doesn't claim it can be found by vnc://name. Have you tried it by ip address? – Tetsujin Dec 6 '15 at 9:14
  • Have you looked at Sytem Preferences/Sharing ? – Milliways Dec 6 '15 at 10:52
  • @Milliways, yes have looked at them. It's all kosher. Which is why sometimes the connection works flawlessly. But not always. It used to be 100%, all the time, in the past. – PKHunter Jan 27 '17 at 6:59
2

Sounds like one computer isn't able to reach the other.

Try using vnc://myhomemini.local

Adding the .local tells your Mac that it should use bonjour (multicast DNS) to resolve the address. If everything is on the same network and multicast is allowed (usually the case) this should allow your computers to find each other.

Another possibility is that your network is configured not to allow hosts to talk to each other. So even though they are on the same network, the router doesn't allow them to talk. Look at the settings on your router to determine if that is the case or not.

  • It's indeed set to .local. That's how I do this, sadly. Instead of clicking the button "Screen Sharing" in Finder, I do VIEW --> Connect to Server (or Command K shortcut) and then choose the latest VNC. – PKHunter Jan 27 '17 at 6:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .