15

I am using whatsapp web version and the iPhone needs to be connected at all times for it to work. However, when the iPhone goes to sleep (screen goes off) the wifi connected is automatically turned off to save battery and the whatsapp on my browser disconnects. Is there a way to force iPhone to keep wifi connection up when locked and/or asleep?

  • It should be connected until you go out of your router's range or manually disconnect. This is a non-Jailbroken Apple iPhone, correct? – RedEagle2000 Dec 5 '15 at 15:45
  • non-jailbroken. But you are mistaken. It disconnects the wifi when it goes to sleep to save battery. I am positive about it. – Peter Mel Dec 5 '15 at 16:10
  • What version of iOS is it running and which iPhone is it? – RedEagle2000 Dec 5 '15 at 16:17
  • lastest version iphone 6s – Peter Mel Dec 5 '15 at 16:25
  • Very strange, I've never heard of anything like this happening before. Does it only disconnect in Low Power Mode or all the time? – RedEagle2000 Dec 5 '15 at 16:27
4

I have the same iPhone and the same problem. I just went into Settings > General > Reset > Reset Network Settings. Then reconnect to your wifi like normal.

This worked for me, however if the problem is still there, maybe turn your data off when using wifi. Hope one method works for you (:

  • 1
    Not sure why this answer is so much downvoted. But for me this solution works! – Alexey May 1 '17 at 15:44
2

I had this problem at my local school where every time I locked my iPod I lost connection to wifi, so I developed an app called 'Constant WiFi' which keeps me connected even if my iPod is locked. I am not familiar with 'whatsapp' but my app forces the wifi to stay connected when the device is locked or asleep. If you decide to try the app I hope it works for you!

1

I have iOS 11.2.1 on iPhone 6 (Verizon), and my wifi connection dropped every time the phone slept, and it always took a moment to switch back from LTE to wifi upon waking, which was so annoying.

What seemed to solve the problem for me was to configure my router to assign a fixed "allocated" IP address to my phone based on its MAC address.

If you have the ability to configure your LAN router, you could try that. For everyone else, it seems Apple has abandoned you.

P.S. I was inspired by this post.

  • This makes sense; the router that gave the IOS device its DHCP service, if it doesn't hear from the device, can reassign that same address. So, it's going into the router settings, not the phone. – Whit3rd Apr 25 '18 at 7:03
1

Setting my network's Auto Login to On seems to have solved the issue for me.

enter image description here

source

IOS 11.3 on iPhone 7, it is working fine now based on "Auto Login" option. Thanks

  • 1
    Worked on iPhone 6s, iOS 11.1.2 – AHHP Nov 26 '17 at 10:40
  • I have iOS 11.2.1 on iPhone 6 (Verizon), and Auto-Join is already enabled, and there is no Auto-Login option for me. And my wifi connection drops every time the phone sleeps, and it always takes a moment to switch back from LTE to wifi upon waking, which is so annoying. – Ryan Mar 12 '18 at 3:13
-3

Change wifi setting password from WPA 2 to WPA. Hope that works.

  • This reminds me of when tech 'support' or articles that advise fixing connection problems say to disable the firewall. Totally unacceptable and a great way for worms to have their way. Another analogy is when you should give the service all privileges and all files should be world read/write/executable. In other words terrible advice that comes from ignorance but that is harmful and just wrong. Then if something 'works' what do people do? They keep it the way that supposedly fixed it! This decreases their security and indirectly others too. – Pryftan Jun 26 at 18:34
  • Just type sudo in front of every command, in fact! Pro tip, have "sudo su" in your bashrc file! – Aron Aug 2 at 7:03

You must log in to answer this question.

protected by Community May 24 '16 at 18:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .