2

On a work iMac 27" Intel i5 that wouldn't boot when I got it. Did a restore to Yosemite. Tried to install El-Capitan, which didn't go well at first (I would download it and then get a message telling me it was corrupt when I tried to install). This morning, I re-downloaded and the install kicked off (progress!). However, it stalled and now shows the grey apple and a progress bar (about 95% completed). It's been like that for hours.

I tried to re-start but it goes right back to this screen. I ran disk utility, but nothing came up.

I'm not a mac user, so I'm not sure what steps to try next. Do I need to do another restore to Yosemite?

2

Apple Support: 1-800-275-2273 (Or you can get it from here)

Call, it wont take long, and you don't need to have applecare or anything like that. And this way, if something breaks, maybe you'll be eligible for some kind of reimbursement.

You can do the whole thing with your phone on speaker. I actually tried to call them myself (and then relay the information) but one of the first things they ask for is a serial number.

The occasions i've called them are all blurred together, but i vaguely remember being told to hold the power button for some specific length of time, holding some key while it started up (which might have been to activate disk utility), and unplugging the iMac.

The key thing, though, is that i called them, it didn't take long, and in doing so i was able to fix it.

  • 1
    Thanks for the response. In the end, I had to wipe the drive, recover to Lion and then upgrade to el-capitan. – Matt M Dec 8 '15 at 19:23
2

A lot of things can could be the cause of the failure to upgrade. Issues include a failing HDD, invalid computer date, corrupted installer image, a corrupted operating system prior to upgrading, and possibly others.

  • A failing hard disk can cause spastic hard drive performance. A failing disk might struggle and lag when attempting to read and write from the disk.
  • I've noticed that OS X installers (at least the newer ones) run some kind of date check prior to starting the installation. My guess is that the installer checks the computer's date to ensure the "date" is after the installer was downloaded. Anyway, the error usually signifies that the "installer couldn't be verified" or something like that. The computer's date can be set using the terminal command date [mm][dd][hh][mm][yy] (month, day, hour, minute, year). This issue is particularly prevalent when running an installer on a computer that has been without a power source for a long time as a power loss will cause the clock to reset.
  • If you are installing off of a USB or network recovery device, the
    installation may have be corrupted either because of a read error or a bad connection to the installation image source. The image originally downloaded from the App Store may also be corrupt. In which case, re-download the image and attempt the installation again.
  • An upgrade is different from a clean installation. A clean installation involves simply installing macOS onto a drive with nothing already on it. An upgrade, on the other hand, involves preserving your files while writing the new OS files into place. Sometimes, when performing an upgrade, there may already be junk on the disk that interferes with the installation process.
  • Another issue I've experienced is failure of the motherboard though your particular issue doesn't hint at a failing board.

There are likely other causes which I have yet to run across.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .