2

I use Time Machine to backup my iMac to a MacBook Pro which is running OS X server. Both are running 10.11.1; the Server version is 5.0.15. Time Machine had been running fine using a 4TB USB drive on the server. Yesterday I added a 6TB drive and switched the iMac to use it (again, over the network).

Now Time Machine fails after about 90 seconds and reports "The backup disk needs 743.84 GB for the backup but only 509.94 GB are available..." The Time Machine System Preference panel then shows "510 GB of 510 GB available," which is strange because before the failure it correctly indicated "6 TB of 6 TB available."

I have doubled checked the formatting of the 6TB drive (HFS+ Journaled, GUID Partition Map) and confirmed that the server also shows 6TB available. I have also reset Time Machine backups (http://pondini.org/TM/A4.html), rebooted both computers, shutdown and restarted the Time Machine service, and basically started everything I know of from scratch twice.

Any solutions or hints will be quite welcome!

1

After a bit of digging into the details, I discovered that the sparse image created by Time Machine was limited to about 500GB (475Gi to be exact). Here is abbreviated output from 'df -h' with both the network share (TMBackups6) and sparse image (disk5s2) mounted:

$ df -h
//xxx@xxx._smb._tcp.local/TMBackups6 5.5Ti 1.7Gi 5.5Ti ...
/dev/disk5s2                         475Gi 427Mi 475Gi ...

Seeing this, I double checked the "Limit each backup..." setting on the server; the checkbox was cleared, which should mean no limits. Still, the evidence pointed to enforcement of the default 500GB limit.

At this point I started thinking about creating the sparse image manually with the limit set to a sensible value. However, I don't do this often a did not relish spending time figuring it out. Instead, I set the limit to 9999GB and now Time Machine is backing up properly. To change the limit,

  1. Open the Server app.
  2. Click on the Time Machine service in the left column.
  3. Double click the backup destination on which to set the limit.
  4. Check the Backup Limit check box.
  5. Change the limit in the text box to be larger than the backup drive.
  6. Click the OK button.

Here is a screen shot (cropped) showing the results of steps 4 and 5 with the check box and text box highlighted in yellow (OK button not shown):

Results of steps 4 and 5

I do not yet know if setting the limit larger than the size of the physical drive will cause problems in the future. I believe from Maverick on, Time Machine is aware of both the physical drive size and maximum size of the sparse image. So don't expect problems.

I am satisfied with this work around for now. If anyone knows the root cause and a real permanent fix, I would appreciate the info.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .