7

I can't set up my Google Accounts on my MacBook Pro. When adding my work (one step) or private (two-step) Google account in the internet accounts panel in system preferences, it doesn't go past this screen. When I select the apps to sync, I can click Done and then Done get's greyed out. I see the grey spinning wheel very shortly. enter image description here

For the calendar, I tried this but without succes: Can't enable Gmail calendar syncing

I've had this issue on Yosemite as well, but now also for el Capitan. Other sites suggest going on a different network would solve the issue. I tried wired, WiFi and a mobile hotspot I created with my phone without succes.

It seems that in the process I'm going one step further than this guy Internet Accounts - Login Issue with Google and iCloud. I'm running out of options and frustration is growing strongly. Thinking about doing a clean install.

5

This issue was plaguing me for a long-time and was really annoying.

I initially thought it was an issue with a random plist or other file hanging out in the Library/ folder and I tried deleting many of them to try and get to the bottom of this.

Eventually, I was tipped off to a Keychain issue by looking in Console, which with some Google'ing, led me to this post on Apple's forums.

Ultimately, I removed all of the following items in Keychain Access, retried adding the account in Internet Accounts, and everything worked well!

Keychain Access items to remove

It sounds like it was only the com.apple.account.Google.oauth* tokens that had to be removed, but your mileage may vary.

  • I ended up reinstalling my Mac, which was overdue anyway. Still it was super frustrating. – Jeroen Feb 23 '16 at 9:15
0

None of the methods mentioned anywhere worked for me. However, I logged out of my iCloud account, added the Google accounts, then logged back into my iCloud. Everything worked after I logged out of iCloud and I got past the grey screen.

0

For me, I also had to delete an entry called:enter image description here

name = "https://gmail.com"

Kind = Identity preferences

That did it for me. I have too many saved credentials with "gmail.com" in them (my email), so searching 'gmail' isn't so easy. Hopefully helps someone else too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .