1

I came across “Copy URL to Clipboard.app” (or “CUTC” for short) in How to access a clicked URL in a URL handler application created in Automator and have been using it for some time now. However, it seems to have stopped working in OS X 10.11, and I have no idea what to do to make it work.

What I've tried

  1. I downloaded the pre-compiled app and moved it to /Applications/ and then launched it manually to clear the quarantine message (“Are you sure you want to open this file downloaded from the Internet?”)

  2. I went to System Preferences » General and clicked the dropdown for “Default Web Browser" but CUTC does not appear as one of the available browsers.

  3. I rebooted my Mac just to make sure. It still did not appear.

  4. I tried https://github.com/kerma/defaultbrowser to set my default browser from Terminal:

    % defaultbrowser -set Copy\ URL\ to\ Clipboard

    Copy URL to Clipboard is not available as a HTTP browser

    (It also listed all available HTTP browsers, which made it clear that OS X did not consider CUTC to be able to receive http/https links, as opposed to some sort of simple syntax error trying to use the defaultbrowser command.)

  5. I re-compiled the app from source in Xcode, and tried using that instead, but had the same results as with the pre-compiled version.

I have no idea where to go from here. I am not a programmer and have no idea what needs to be done for an app to register itself as able to receive http/https links.

The Problem I Am Trying to Solve

I have used CUTC as my default browser in the past so that I could process URLs using shell scripts before handing them to another browser.

If there is another app out there which is capable of receiving http/https links clicked on from other apps (mail, Tweetbot, etc), I would be equally happy to try that.

  • It should be enough that the Info.plist of CUTC contains an array of CFBundleURLTypes, such as http and https. developer.apple.com/library/prerelease/mac/documentation/Carbon/… The git code for CUTC has the required info though... No idea why it's not getting picked up correctly. You might try removing stray xattr from files in the app, or also chmod -N to clear out ACLs which might prohibit execution. – Kent Dec 7 '15 at 6:50
2
+100

The CFBundleURLTypes tag in the Info.plist file just needed a wee bit of a change and now it works on OSX v10.11 El Capitan.

This following worked okay in previous versions but isn't recognised in El Capitan.

<key>CFBundleURLTypes</key>
<array>
    <string>http</string>
    <string>https</string>
</array>

However if you change it to the following El Capitan recognises it and offers the "Copy URL to Clipboard" application in the "Default web browser" drop-down menu in System Preferences.

<key>CFBundleURLTypes</key>
<array>
    <dict>
        <key>CFBundleURLName</key>
        <string>Web site URL</string>
        <key>CFBundleURLSchemes</key>
        <array>
            <string>http</string>
            <string>https</string>
        </array>
    </dict>
</array>

I've submitted a pull request to houbysoft but in the meantime you can download an updated binary here.

  • YES! The updated binary works perfectly for me. Thank you! – TJ Luoma Dec 8 '15 at 15:13
  • I just merged in your pull request :) – houbysoft Dec 12 '15 at 1:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .