I installed the driver of TP-Link's wireless network adaptor, and it ships with a wireless network utility which shows an icon on the menubar.

It is invalid to click or drag this icon, and I even can't find any switches to turn it off.

It looks like this:

  • 1
    Have you tried holding the Command key and removing it (drag it off)?
    – Arc676
    Dec 2, 2015 at 11:30
  • I tried but failed... Dec 2, 2015 at 11:31
  • You say "it's invalid to click". So, it's an icon that does nothing? If you click it nothing appears?
    – Arc676
    Dec 2, 2015 at 11:32
  • 1
    Yes, it just sticks on the menu bar and provides nothing, no popup menu no blinking... Dec 2, 2015 at 11:36
  • If you remove this software how can you connect to a wifi network? :O Jun 2, 2018 at 22:01

7 Answers 7


The menubar icon is related to StatusBarApp.app

Possible paths:


# for version 5.0 (2016) on Mojave
/Library/Application\ Support/WLAN/StatusBarApp.app/

You can close the app by killing the process via the Activity Monitor mac app or entering:

killall StatusBarApp

Note: The app will still open next time you restart the Mac

The app is loaded by launchd while booting. The related plist should be located at /Library/LaunchAgents/ and the file name is Wlan.Software.plist.

To unload the launch agent enter

sudo launchctl unload Wlan.Software

To permanently remove the launch agent enter

sudo launchctl remove Wlan.Software

Alternatively you can remove the file /Library/LaunchAgents/Wlan.Software.plist.

After a reboot the icon should be gone.

I have tested this with the installer TL-WN725N_V2_150901. Since you didn't specify any adapter (or driver) in your question the name of your app/plist may differ. Please check this with launchctl list or launchctl list | grep -i wlan.

  • My network adaptor is TL-WN822N Ver 3.0. Wlan.Software.plist can be found at /Library/LaunchAgents, but the output of sudo launchctl unload Wlan.Software.plist is /Library/LaunchAgents/Wlan.Software.plist: Could not find specified service. Dec 2, 2015 at 12:09
  • I removed Wlan.Software.plist and rebooted my computer, the icon has gone... Dec 2, 2015 at 12:14
  • @user3824053 Sorry, copy and paste error ;-). Just remove the .plist part in the sudo lauchctl ...command. I have updated the answer.
    – klanomath
    Dec 2, 2015 at 12:14
  • It does work, thx for your help. :) Dec 2, 2015 at 12:15

Just alt + click(left) and uninstall option appears.

  • 1
    easy and quick: this should be the correct answer :)
    – numediaweb
    Nov 28, 2020 at 10:20

in macOS Big Sur

Option + Left(Single) Click

On a Macintosh, the Alt key is called the Option key

enter image description here


Alternatively, if you still have the driver installer zip from DLink, there should be an Uninstaller package in the archive. I had the drivers for the DWA-192 wireless adapter and was able to fix the same issue you were having with the icon by running Uninstall.pkg. This should also remove other specific driver files that were copied during initial installation.


i downloaded the driver from d-link (in my case it was https://eu.dlink.com/uk/en/products/go-usb-n150-wireless-n-150-easy-usb-adapter?revision=deu_revb#downloads). The zip file includes both the install and the uninstall package, so i ran the uninstall and voila. icon and driver are gone.


Actually, you can ALT+click on the menubar item and an "uninstall" option will appear. worked perfectly for me.


use cleanmymac 3 for remove te menubar icon

  • We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.
    – Tetsujin
    Apr 18, 2016 at 6:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .