4

I updated to the newest Xcode version 7.1.1 in the hope, that the performance will be better. But no, performance is much worse again.

When typing a word, an indexer starts immediately and CPU is on max. In general there is mostly a process running full, even I am doing nothing. There are no other apps open, but the CPU is mostly running. (mdworker, WindowServer, Xcode, SourceKitService…)

I already disabled Spotlight from indexing my source code.

Are there any hints, tutorials or the like to tune OS X and Xcode, so it will be more performant. I am using Swift as programming language.

  • What model of Mac are using? How much memory and free disk space does it have? – Graham Miln Dec 2 '15 at 13:21
  • Diskspace : 160GB. Memory: 16 GB. It is always indexing and SourceKitService is on High CPU most time. When typing one character it starts for some seconds. Typing is laggy. – user1344545 Dec 13 '15 at 8:50
  • @user1344545 You deleted your VMware question so I have to choose this detour. Here is an old answer to a similar question! – klanomath Jan 18 '16 at 15:38
  • Upgrade your Mac then. – GeneCode May 23 '16 at 5:55
1

Disable autocomplete, that should help. Xcode -> Preferences -> Text Editing "Suggest completions while typing" - uncheck it. If you feel your Xcode is still sluggish, disable the other options, too. You may want to keep "Turn on Use Escape key to show completion suggestions" on just incase you need some hints occasionally.

  • Thanks for helping, but this didn't help in getting better performance. SourceKitService still is always high, when typing. – user1344545 Dec 31 '15 at 8:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .