5

My Time Machine in Finder shows the correct icon, however, on my Desktop, it shows the Yellow icon that is used for normal external hard drives. It only changes on the desktop to the time machine icon when I either eject the hard drive or in terminal use, killall Finder. But ejecting it is kinda useless as I can't use it then, and if I then reconnect it, it shows the yellow icon again.

I'm running the latest version of OS X El Capitan.

Anybody else have this issue or know how to fix this?

  • Confirmed, I see the same with an internal TM drive. It has the normal grey icon until I restart the Finder, then gets the green TM icon. It still works for backups, just doesn't get the icon. Best idea might be to file a bug report at bugreport.apple.com – Tetsujin Dec 1 '15 at 8:12
5

To fix this I went into Get Info for the external drive and under the "Preview:" section it showed the TM icon, which I clicked and dragged to the top of Get Info and it overlayed the yellow icon.

  • This worked. Thanks a lot. It's been so frustrating seeing the yellow icon instead of the time machine icon. – dhruveonmars Mar 19 '16 at 18:49
  • For me, the Get Info window also showed the orange disk icon. The answer below from grandpa worked for me. – dunxd Jul 31 at 8:59
2

For me it fixed by following these steps:

  • Go to System preferences > Time Machine
  • Go to Select Disk...
  • Select the disk which is showing yellow icon
  • Start the backup

This will remark the disk as Time Machine Backup and macOS will change the icon to the Time Machine green icon.

  • This worked for me if I selected the disk from the Available disks list. If you select it from Backup Disks then remove disk and add it again it didn't work. – dunxd Jul 31 at 8:57
1

I just had this same problem after using Migration Assistant to move my data to a new Macbook. I told the new machine to "inherit" my existing Time Machine backup. Backups worked fine, but the wrong icon was shown for the drive (orange instead of blue with arrow). The correct blue icon was shown momentarily when I ejected the disk, but it kept coming back orange when I reconnected the disk. I went into the Finder preferences and in the "General" tab, under "Show these items on the desktop" I unchecked "external disks" then re-checked it. The right icon was then shown on the desktop. However, the wrong icon was still displayed in Finder windows. Doing "get info" on the incorrect icon in the Finder window caused it to immediately refresh to the correct icon.

This Time Machine troubleshooting guide also has some more elaborate fixes: http://pondini.org/TM/B4.html

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .