I created a partition to run Snow Leopard on my computer running El Capitan and no longer need it. I allocated 20GB to that partition. Here's what I've done. I first go into Disk Utility, select my partition and click 'Erase'. It apparently erases everything but there is still 67.4 MB being used on the partition that I can't remove:

enter image description here

If I go into finder this is what I see on that partition:

enter image description here

Those are hidden files obviously and I can't delete them. I then go to the hard drive itself and click 'Partition' but when I do that and select the partition I want to remove, the minus button isn't an option:

enter image description here

I can't manually resize the partitions either (I want to re-allocate the disk space to my main drive).

Any ideas on why I can't remove the partition?

  • Is either partition encrypted? Are you running FileVault at all?
    – ash
    Nov 30, 2015 at 21:19
  • @ash, I don't believe so. I haven't done either of those (and haven't really heard of it) so I'm guessing the answer is no. Dec 1, 2015 at 0:01
  • Since this is still being heavily viewed - i'll add my 2 cents: I was booted from external and trying to merge my 2 main partitions. couldn't get it to work until I UNMOUNTED all the volumes. Then "-" ungreyed and the resize worked.
    – Jason
    Sep 15, 2019 at 11:06

6 Answers 6


Another cause of the "minus" button being greyed out in Disk Utility is that it doesn't allow you to delete the first partition on the disk.

  • I think that might be the issue i'm facing. I have a USB SDD with several Beta's of MacOS and I want to delete the oldest but it has no - button. Any idea how to work around this?
    – Darren
    Sep 25, 2020 at 10:47
  • Okay, but that's not useful: it's just a partition, how does one solve this problem? Sep 27, 2021 at 3:48

I've had the same issue in El Capitan. The instructions above which feature the old version of Disk Utility are obsolete as the new version (El Capitan and up) does not offer the same set of options.

That said, in order to remove the extra partition for which the minus button was greyed out, I simply rebooted into Recovery Mode (CMD+R during boot) and ran Disk Utility from there. The button was no longer greyed out.

Hope this helps!


I solved this on my external drive using diskutil to merge the problem partition with a following partition. Update: Klanomath points out this won't work if you've booted from the disk you want to modify.

Note: Data will only be preserved on one of the partitions (the first mentioned in the diskutil mergePartitions ... command) so create a backup first if you need to.

Get a list of partitions on the drive. Leave out the disk identifier disk2 if you want to see all disks

diskutil list disk2

Merge the problem partition with the following partition giving the merged partition a name, say MyNewPartition

diskutil mergePartitions HFS+ MyNewPartition disk2s2 disk2s3

This results in all the data from disk2s3 being deleted and disk2s2 being extended into the space that was used by disk2s3

In my case the merged partition still could not be resized or deleted in Disk Utility but at least I had removed the unwanted partition.

  • 1
    This answer doesn't solve the problem because here the (external) disk is no disk the Mac booted from. Additional you don't have to erase disk2s2: the command diskutil mergePartitions HFS+ MyNewPartition disk2s2 disk2s3 only deletes the data of the third partition and the second partition is extended while preserving its data!
    – klanomath
    Mar 26, 2016 at 23:04
  • @klanomath If you first created and booted from a clone, would you then be able to merge partitions on the internal disk?
    – David
    Mar 27, 2016 at 9:36
  • If you boot to Internet Recovery Mode you should be able to merge partitions. But disk0s2 and disk0s3 probably are the main OS X volume and the Recovery HD. So you'd have to merge disk0s2 and disk0s4 (and all partitions in between) to remove the Snow Leopard partition and rebuild the Recovery HD later.
    – klanomath
    Mar 27, 2016 at 10:55

I booted osx from an external drive and used disk utility to select internal drive and erase the drive completely giving me back full disk space. probably back up first :)


In Disk Utility, there's a difference between deleting and erasing.

Erasing a partition simply clears all data on that partition. The leftover .blah files are OS X config things. The partition still exists on the disk, it just now doesn't have anything in it.

Deleting a partition means removing the partition from the partition table. That partition will then no longer exist.

From your question, you would like to delete the partition completely. Thus:

  1. Click on Apple SSD SM02... at the top of the Disk Utility drive menu. This is the Red box on the image below.
  2. Click on the Partition tab at the top of the window. This is the green box.
  3. Select the Snow Leopard partition, then click the minus sign at the bottom of the partition display. This is the purple box.
  4. Click Apply, and Disk Utility will work its magic. This is the black box.

Disk Utility Partition Deletion Steps

The names and OS X version in the image are different(I think that is from 10.9), but the steps and buttons are the same.

EDIT: This may be a workaround if you do not have the minus button:

  1. Make a Time Machine backup of your main OS X hard drive. It is probably a good idea you store this on an external hard drive or in the cloud.
  2. Restart your Mac in Recovery mode by holding down Command + R when you turn it back on
  3. Go to Disk Utility
  4. Reformat the Snow Leopard partition as OS X Journaled through the erase tab
  5. Now try to delete the partition
  • 2
    I mentioned in my message that I don't have the option to choose the 'minus' button when I click on the partition. It doesn't give me that option. From other tutorials and threads, they explained that I have to 'erase' the partition first and then remove it which is why I was using erase as well. Dec 1, 2015 at 19:04
  • Yeah, you do have to erase it first. The minus button still isn't avaliable?
    – Kisa Ayano
    Dec 1, 2015 at 19:28
  • No it's not available. That's basically the issue here. It's 20 GBs I can't seem to re-allocate to my main drive. Dec 1, 2015 at 21:01
  • Hmmm.... Your best bet then may be to boot into a live CD of Linux and partition from there. Backup before you do this!! I can post a guide if you would like one.
    – Kisa Ayano
    Dec 1, 2015 at 21:02
  • Ok if that's the only way than a tutorial would be good but it seems like there must be a simpler solution to it? Dec 1, 2015 at 21:10

In order to delete the partition I wanted to, I had to delete the other partitions to the "left" of it (counterclockwise from the it in the partition pie chart), which for me included a backup partition. I was eventually able to remove all partitions, which was my goal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .