2

I’m looking for some advice regarding a specific problem with a MacBook Pro mid-2009 running the latest version of El Capitan.

The basics follow, but I have shared details of the troubleshooting steps here (link to a thread at Apple Support Community).

1) MBP suddenly refused to boot from its Internal HD (an SSD I installed two months ago: worked fine until the incident).

2) The disk is fine and can boot in external configuration.

3) Also, I tried with a different HD (a clone, not SSD, but standard). But whatever HD I use in the original internal bay, it won’t boot, and won’t mount.

4) I’ve checked the internal SATA cable: I ordered and tried a replacement cable. Same results. It is unlikely that both the original and the replacement cable are faulty.

5) Since it’s a mid-2009, I was able to replace the original optical reader (DVD) with an HD bay (a customize kit, easy to install). The MBP can boot and operate just fine with the HD when it is installed in this configuration. So I can still use and operate the MBP pretty much as usual, with a working internal HD. But the original HD bay/location is unusable.

Is there a way to push the troubleshooting further? If the problem is beyond the HD and internal SATA cable, does it man it’s on the motherboard? Anything to try there? Maybe there’s more to explore with the SSD vs. standard HD?

  • any solution? I'm having the same problem on a mid 2012 mbpro – Tanonic Apr 3 '17 at 18:50

You must log in to answer this question.

Browse other questions tagged .