2

As usual I wanted to prepare bootable USB with OSX. Some time ago I've made a copy of my Mavericks, Yosemite and El Capitan to external drive.

I wanted simply to drag & drop El Capitan to prepare USB drive.

After dragging El Capitan app file to desktop I get

enter image description here

The point is, that my Desktop does not contain this file. What's wrong? The same happens to all 3 files. I cannot copy them. Are those files corrupted? In a meanwhile I'm downloading new file form App store...

This disk was plugged into Windows multiple times. Is it possible that Windows damaged app files? I've noticed that Windows treats app files as folders so maybe it changed the content?

  • From your screen capture, it seems that you already have a file (or folder) named "Install OS X El Capitan.app" on your Desktop. The error message seems to be a correct one. – dan Dec 4 '15 at 7:13
  • This window is from my external USB drive. Not the Desktop. – Matt Komarnicki Dec 4 '15 at 7:15
  • And just below the Finder window of your USB content is the icon of the existing file (or folder) named "Install OS X El Capitan.app" which is on your Desktop. – dan Dec 5 '15 at 10:50
1

This is a known bug in the Finder app of OSX. Options you can try :

  • Instead of drag-dropping you can try right click -> Copy Item and then paste it on the desktop
  • Try copying the files through terminal command.
  • Try making a folder on the desktop, and then copy the files in the newly created folder.

Reference : Apple Discussions.

1

I tried Terminal even as the first option but no luck in my iTerm. Then I tried all combinations with dragging and dropping and right click copy and paste. Nothing worked.

Finally I went level up and dragged and dropped parent folders called OSX. First time it just created empty OSX directory in my Desktop with the same error message. But when I did it for the second time, it started copying all 3 big installers.

It's absolutely weird. So finally it's done. I'm writing this response from clean, formatted El Capitan.

Up for Shaggy for all efforts!

  • I'm glad i could help. As i mentioned in the answer, it is a bug in the Finder and it's behavior is totally random. Please consider accepting it if it helped you. – Shaggy D Nov 28 '15 at 10:12
  • @ShaggyD, you said that this is a well known problem on El Capitan. I see that now it happens with all files I copy form external USB. Can you paste some link to this problem? – Matt Komarnicki Nov 28 '15 at 10:34
  • The problem is not on El Capitan, it's in the Finder app. The link I've given in my answer is the only relevant link that addresses this problem. – Shaggy D Nov 28 '15 at 18:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .