2

So I have this weird problem. I can connect to the App Store via iTunes on my Macbook. However, if I try to connect via the iPhone appstore using the same email and password I get:

"Verification Failed Your Apple ID or password is incorrect" error message "

I have already tried resetting my password via Apple ID management and successfully changed my password with a new one. I still get the same error message. Any Ideas?

Edit: The problem occurs in only one of the iTunes account I use (Polish Appstore account). I can connect to my other account thru both my iPhone and my Macbook without any problem. So, I do not think there's a problem with the iPhone or its settings. I also don't think that it has anything to do with my internet connection.

  • I had this same problem a while ago and found out my cellular provider was pushing ads and redirects in the http traffic. Any time there was an ad "due", all traffic on https stopped until the ad was displayed via http. Changed provider since. – EDP Nov 27 '15 at 18:57
  • I don't think my problem is the same. Because, I can connect to my other iTunes accounts with no problem. This particular iTunes account is a Polish account I created to download apps available only in Poland. I had no problem with it until a few weeks ago. All of sudden it started giving me the above error. – Ahmedov Nov 27 '15 at 23:02
  • Did you ever fix this? I had the same issue trying to log in with my US iTunes account. My UK account was fine. This fixed it Settings>iTunes and App Store > logged out of existing account and logged in with account I wanted. – user170055 Feb 12 '16 at 22:28
  • I have the same issue, and have had now for several months - I have not yet had the patience to contact support. Perhaps it's related to switching between accounts from different countries, as I also use 1 account in one country and 1 in another so I can get apps in both languages. – fantabolous Jul 18 '16 at 3:06
  • the issue somehow disappeared. I tried so many things that I don't remember which method was actually the successful one :) – Ahmedov Jul 18 '16 at 9:16
1

If the servers are broken or the network isn't working between you and the servers, your password isn't actually wrong. Even when all lights are green at http://www.apple.com/support/systemstatus/ it could be an issue that'e exclusively server side, and you'll need Apple Support to get to that conclusion.

Barring that, you can certainly to go through "the usual troubleshooting steps" on iOS since you're unlikely continuing to type the password incorrectly.

You should start with the support article below:

Before you contact support (the link at the bottom of the page - the next step if that doesn't work) is to maybe try a restart. Since the app store needs an accurate time and date:

  1. Sign out of the store from preferences
  2. Turn off "automatically set time" in the settings app, General, Date & Time
  3. Put the device in Airplane mode
  4. power off the device and maybe go make some tea while it powers itself off
  5. When you start it up again, set the clock manually to within 10 seconds of a good time source and then enable WiFi or cellular data as you please.
  6. Try to sign in to the Settings App - iTunes & App Stores section
  7. After one failure, turn on automatic time setting
  8. Try to sign in to the App Store
  • Thanks for the reply. I have tried all of the above 8 steps in proper order. Unfortunately, I get the same error. – Ahmedov Nov 27 '15 at 23:13
  • 2
    @Ahmedov Then you're ready to contact support knowing you put in above average troubleshooting. The store and some accounts do have errors from time to time and you might need them to assist. – bmike Nov 27 '15 at 23:57
-2

THANK YOU!! GOT IT FIXED BY FOLLOWING THIS INSTRUCTION:

This fixed it Settings>iTunes and App Store > logged out of existing account and logged in with account I wanted.

  • well, the problem is, this doesn't work – Ahmedov Aug 15 '17 at 7:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .