0

Numbers was installed with a different Apple ID to mine (my bosses), so it won't let me update it (when it prompts for credentials, you can't overwrite the user name). I therefore need to reinstall it using my Apple ID.

I dragged it from Applications to the trash then restarted the App Store. However, it still insists there's an update (which prompts me for my bosses credentials again). I've tried all the tricks I can find to tell the App Store to refresh:

  • ⌘+R
  • turning on debug mode and telling it to reset
  • deleting the download cache

Nothing has worked.

How do I blow Numbers away and reinstall it using my own credentials?

  • Have you emptied the Trash? – pdd Nov 24 '15 at 23:45
3

For Apple's "free" apps, such as Numbers, I've had success doing the following:

  1. Leave Numbers.app in the /Applications folder
  2. Start App Store, and check for updates. This should show an update for Numbers, but do not try to update it yet.
  3. Move Numbers.app/Contents/_MASReceipt/receipt to your Desktop
  4. Go back to the App Store, and update Numbers

This will download the new version, and create a new receipt file, with your new ownership credentials.

NOTE: This may not work if your second set of credentials is not already authorized to download Numbers via a different Mac, etc.

0

There's also an uninstall tool available for App Store apps which can be run from the command line. Here's how to use it:

  1. Log into the Mac in question

  2. Verify that your application was installed by the Mac App Store

  3. Open Terminal

  4. Run the following command with root privileges:

    uninstall file:///Applications/Application_Name_Here.app

  5. You will be prompted to authenticate with an administrator’s username and password

enter image description here

  1. The application should then be uninstalled.

enter image description here

Based on my testing, it appears that the uninstall tool has the following requirements:

  • The uninstall tool must be run from a account that is logged in at the console.
  • The uninstall tool must be able to display the authentication dialog window.
  • The application being uninstalled must have originally been installed by the App Store.
  • The account running the uninstall tool must have both administrative rights and sudo privileges, in order to run the command with root privileges and properly authenticate at the authentication dialog window.

For more information, please see the link below: https://derflounder.wordpress.com/2014/08/17/uninstalling-app-store-apps-from-the-command-line/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .