The keyboard shortcuts Option-Left/Right Arrow is made for moving the cursor by words, as Apple described here: https://support.apple.com/en-us/HT201236 , but doesn't work on my MacBook Pro (15-inch, Mid 2010, OS X 10.11). They fail to work everywhere I can try, including but not limited to Notes, TextEdit, Mail, Google.com search field and iMessage text field. Meanwhile on my friend's MacBook Air (13-inch, Mid 2013, OS X 10.11), they work damn well! Anyone can help?


  1. An Apple Wireless Keyboard is paired to my Mac, but it doesn't help.
  2. System has been restarted several times, doesn't help.
  3. Including Option-Delete and Option-Shift-Up Arrow, all the Option related shortcuts in the "Document shortcuts" session of https://support.apple.com/en-us/HT201236 doesn't work.
  4. The Option key is fine, I have tested it by shortcuts like Command-Optiono-H which works.

2 Answers 2


The problem has been solved by switching the input source from "Unicode Hex Input" (my major input source) to "U.S.". I think some option based shortcuts can't function as usual with "Unicode Hex Input". You can update the input sources by searching "unicode" to be directed to system preferences -> Keyboard. Click "Input Sources" and remove other input methods that might be causing the error. Then open a new window for the program you want to test.

  • Do you know how to switch the input source?
    – Code42
    Nov 20, 2018 at 5:57
  • To add to above answer. It wasn't sufficient to merely do the switch. At least on my system, I had to delete the Unicode Input sources as many applications were still defaulting to them. Jul 29, 2019 at 2:36
  • Thank you! This solved my problem. - I added a new Keyboard Input Source - Made sure the Input Sources are shown in the Menu Bar - Switched to a different Input Source - Tested "option + Left/Right", works! - Switched back to my original Input Source - Tested "option + Left/Right", works!
    – barryels
    Apr 22, 2021 at 7:31

Another problem here can pop up if you have a gaming keyboard. I have a g/pc button that is activated by fn + f12 that turns this off. I always forget about it and then remember when I visit this link, so dropping it in for next time :)

  • I appreciate this post, I always forget about the g/pc toggle. It causes such weird inconsistencies. For reference, my keyboard is the Max Keyboard Nighthawk-X7.
    – Adam
    Jul 18, 2022 at 14:56
  • Thanks! This was my problem. Corsair Strave K70 MK2, I had the "lock" on.
    – spider
    Dec 17, 2023 at 17:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .