15

I have this app with a greyed out icon which I'm trying to delete.

enter image description here

I tap and hold, and it asks me if I want to delete it and its data. I confirm and nothing happens.

I try to open it and nothing happens.

I go to Settings>General>Usage and it's not in the list.

I reboot the device and it's still here.

Is there another way to force deletion of this (ghost) app?

  • Have you tried force restarting your device? (Hold Home and Sleep buttons) – caseynolan Nov 24 '15 at 3:58
  • @caseynolan yes I tried that – greener Nov 24 '15 at 18:25
24

Go to settings, general, storage & Icloud usage , manage storage, check the app list click on the app and delete

  • 1
    I would give you 10 upvotes if I could. – Jon Crowell Feb 2 '17 at 23:42
14

If you have deleted an app but grey icon of that app is still there on screen and you are unable to get rid of it then try this procedure:

Go to App Store - Updates - Purchased

That Grey icon application is listed there and there is a Cloud icon in front of it.

  • Click on that Cloud icon to download it again
  • Let it download little bit…
  • …then click on that cloud icon once more to stop downloading.

Problem should be solved now.

4

If you just wait a day, usually the system gets done or gives up on whatever it thinks it's doing with the app in question (and that's why it's grey).

If you can't wait longer, put the iPad in airplane mode and power it off the normal manner - hold sleep/wake and then slide to power off.

When the device starts with no network access, whatever process marked that as "deleting" or "installing" should be released and you can delete the app.

If that fails, you have a harder issue and might need to do a backup or connect to iTunes to erase the app. Once you've resolved it, re-enable the network and get a backup to make sure you have a clean one to rely upon going forward.

  • I don't see the app in the list on iTunes.. – greener Nov 23 '15 at 20:02
  • @greener Then you might need to avail yourself of the wipe or remove from device options. Or, what about downloading the app to iTunes and then "instilling" it from the computer? Hopefully you don't have to wipe the phone and restore from a backup. – bmike Nov 23 '15 at 20:28

You must log in to answer this question.

protected by Community Jun 9 '16 at 14:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .