0

In the following I'll try to explain and ask in the best way I can. I couldn't find any solution for my problem using Google. So if there are any solutions, please point me to them. If you need more information to help out please let me know which information you need.

I don't have lots of information on my problem as I come from a Linux world and don't have experience using OS X. I tried to add a line to /etc/fstab in order to permanently mount a network share.

I added a new line to OS X Yosemite's /etc/fstab using vi. After reboot /etc/fstab disappeard. Consequences:

  • Internal HDD (second drive) didn't mount anymore.
  • USB drives didn't appear on Desktop.

Thus I made some research and learned:

  • Used vifs to edit /etc/fstab.
  • /etc/fstab is depricated.
  • Disk Utility does not help.
    • Show usb-stick but cannot mount. Error: 'Mount failed. The disk "" could not be mounted. Try running First Aid on the disk and then retry mounting.'
    • 'Verify Disk' says everything is ok
    • 'Repair Disk' also works fine
  • It is hard to find information on this topic.
  • If I mount drive manually using mount as root user, drive appears in GUI and seems to be fully accessible (ex. can be "savely removed").
  • My problem could be somehow related to /etc/auto_master and /etc/autofs.conf.

    $ cat /etc/autofs.conf | grep -v ^# |sort | uniq
    
    AUTOMOUNTD_MNTOPTS=nosuid,nodev
    AUTOMOUNTD_NOSUID=TRUE
    AUTOMOUNT_TIMEOUT=3600
    
    $ cat /etc/auto_master
    #
    # Automounter master map
    #
    +auto_master        # Use directory service
    /net            -hosts      -nobrowse,hidefromfinder,nosuid
    /home           auto_home   -nobrowse,hidefromfinder
    /Network/Servers    -fstab
    /-          -static
    /Volumes        auto_custom
    

I managed to create an entry in /etc/fstab so second drive mountes again.

My Questions:

  • What shall I do to make USB drives mount again using GUI only?
  • What happend? Why did /etc/fstab disappear?
-1

Removing entry:

    /Volumes        auto_custom

In /etc/auto_master answered first question and solved my issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .