2

I updated to OSX El Capitan a few weeks ago, and ever since I did so, my computer is having some issues with my Seagate USB 3.0 hard drive.

In terminal, when I use the disk utility, the drive shows up, but it generally will not mount. I say generally, because occasionally the drive will mount, but it is unusable (Time Machine and disk utility give me issues).

I have tried reformatting the drive with no luck - the disk utility says that it cannot unmount the drive.

Any thoughts? Happy to take screen shots if needed.

2
  • What is the model of the drive?
    – user158489
    Nov 23 '15 at 2:09
  • 1
    @NicolasMartin the drive is a seagate srd00f1 Nov 24 '15 at 3:13
1

I have a Seagate external drive and found that the NTFS for Mac OS X had to be removed and reinstalled. (Apple logo / Preferences / NTFS for Mac OS X - right click and remove) This link will take you to the free update. It worked for my Seagate drive but no my Octigen one. http://www.seagate.com/gb/en/support/downloads/item/ntfs-driver-for-mac-os-master-dl/

1
  • I appreciate the help, but it's not working for me. Still not recognizing the drive even though the drive is lit up (the light) Dec 29 '15 at 3:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .